Problems with updating Tachiyomi

So I am on tachiyomi version 13.6. On fdroid site tachiyomi is still on 13.6. on fdroid app the lastest version is 13.6. but fdroid app still say there is a update available. When i click update, it downloads ~28MB which is unusual for tachiyomi app. The Version fdroid app download is 14.1.
Update install fails everytime.


Update fails everytime.

Sorry for bad English.

Also why tachiyomi devs doesn’t support fdroid officially?

It’s 14.1 for me.

Now there are 4 apks every version for different abis.

What’s you device arch? Is it an arm32 device?

Maybe Copyright infringement report (#195) · Issues · F-Droid / admin · GitLab

  1. Tachiyomi | F-Droid - Free and Open Source Android App Repository
    It still there. and still got updated till 13.6.

  2. I mean since i have have 13.6 already installed. The store doesn’t show 14.1 version but still notifies that a update is available. If you doesn’t have tachiyomi installed on your device it will show 14.1 in version history.

  3. Fdroid uses universal package for all apps with some exceptions like fennec f-droid. I don’t think it has changed. Even if they started using splitted builds, The fdroid client should install compatible build. So that’s not a problem I think.

  4. Yes. It is arm32.

  5. Fdroid devs never took it out. And it has been kept updated too. I believe screenshots were the only problem and they took them out.

I think it maybe some problem with signing.
The problem is that I can’t update from 13.6 to 14.1. where 13.6 is installed from fdroid itself.

Interesting. It’s only in the staging.f-droid.org.

I can’t reproduce it. Could you please try another F-Droid app, e.g. neo store, and tell me what happens?

It’s changing! :wink: You’ll see more splitted apps. For details, see Migrate universal apks to split apks (#2809) · Issues · F-Droid / Data · GitLab.

But we still have a problem, see Set ArchivePolicy default value based on VercodeOperation (!1237) · Merge requests · F-Droid / fdroidserver · GitLab. Currently you can enable the archive repo.

Yes. It is arm32.

So we have 4 apks for a version and the arm32 one has the lowest version code, which is moved to the archive repo…

You need to check their issue tracker. I guess they just don’t have time to support a channel they can’t control directly.

2 Likes

I’ll fix the problem.

I just checked, Fdroid client just downloading X84_64 build. so thats why installs fails every everytime. But still, its very bad behavior from official Fdroid client app that it thinks there is a update available and it downloads it as well. Even tho its is not compatible with the targeted device which is armv7a.

Thanks, enabling archive repo solved my problem as arm build was there. will wait for 14.2 till it gets into main repo.

Also good thing that Fdroid working on splitted apps. I wanted fdroid to have them for long time. :slight_smile:

Yes, so please don’t enable the include incompatible versions option in settings.

It should be back to the main repo in the next index update.

Me too. :wink:

Le caught. I am sorry dev, I just realized I wasted your time here.

I enabled that option so that if any app drop support for my device, I will at least able to know.

edit: I realized that I actually cleared Fdroid app data many times to fix this. That disabled that option but it still tried do download and update the app.

Sounds like a client bug. If you can still see that please open an issue.

Does fdroid remove analytic from tachiyomi

Yes. acra is disabled by default.