Privileged extension & unknown sources

privileged-extension
#1

Hello,
I am running LineageOS, and I have flashed Privileged extension 0.2.7 with the zip file.
Then installing StreetComplete, I got the well-known message about security and I have to enable the parameter to allow unknown sources installation.

From what I have read, it is not supposed to be required anymore with Privileged extension installed… Did I miss something ?

#2

Did you enable the privileged extension in the F-Droid settings?

#3

Yes, Privileged Extension usage is checked in F-Droid settings (it was already checked when I looked at).

#4

When you search F-Droid for “privileged” you get two entries:

  • org.fdroid.fdroid.privileged.ota_2070 this is the one you downloaded and flashed
  • F-Droid Privileged Extension this one should display as installed now. If not something went wrong while flashing.

Also I assume your device is rooted?

#5

Please see https://gitlab.com/fdroid/admin/issues/65#note_59105865

2 Likes
#6

Answer is Yes for both : F-Droid Privileged Extension is displayed as Installed, and device is rooted.

#7

Thanks. So it appears to be a defect that will be fixed soon. Good to have the explanation, thanks for that.

#8

Here is the thing. With the privileged extension installed, here are the steps to installing an app:

  1. Click the “Install” button.
  2. Wait for the app to download
  3. After the app downloads, you will see an “Install” button
  4. Do not click the second Install button. (That button is for installing WITHOUT the privileged extension).
  5. The app will install automatically.

Without the privileged extension, you have to:

  1. Click “Install”
  2. Wait for the app to download.
  3. You will see a second “Install” button.
  4. Click the second “Install” button
  5. An Android system dialog will popup asking you if you want to Install
  6. You will click Install on that system dialog
  7. The app will install.

The procedure for installing apps without the privileged extension only works with “Allow Unknown Sources” checked in settings even if the privileged extension is installed. Further, once you click that second install button, F-Droid will not install the app until
A) You download it from a different repository (such as a friends phone)
B) It clears its cache and redownloads the app
C) You turn on “Allow Unknown Sources” and install normally (ignoring the privileged extension)

Also, a phone does not have to be rooted to use the modern versions of the privileged extension.

I hope this helps.

#9

I tried your steps, but that does not work.
As soon as the download is completed, Installation starts (no need to click install again).
I can see “Pre-production de l’application” at the top (french), then the dialog box appears about unknown sources.

#10

Did you try clearing all data for F-droid? Like the cache and everything in Android Settings?

#11

I set the f-droid cache duration to one hour, then wait for the cache being cleared to make sure download starts again.
Btw, I did not mention I run LineageOS 14.1 and F-Droid 1.0.3.

#12

I did have similar problems when trying to install StreetComplete on Lineage. I just thought it was the two install buttons bug that I discovered soon thereafter. However, maybe there is another bug I haven’t noticed yet.

closed #13

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Mastodon