Possible issue with Fdroid app

client

#1

Hello,

I’m not yet sure if this is an actual issue or just me doing something stupidly wrong so I’m reluctant to create an actual ticket for this yet.

I recently moved from CM13 to LineageOS 14.1 (Nexus 5X) and my private repo stopped working. I get “Error getting index file” whenever I try updating my repo in F-Droid. I haven’t changed anything prior or post upgrade in my repo so I’m doubtful that’s the issue.
I can access all the apps and both Index.xml and index.jar through the browser and I have been downloading them like that so far but it’s quite annoying.
The server is running Debian stable with Nginx and the older version of the F-Droid server that is available in Debian (0.2.1-4). The newer version had some issues with creating the jar so I kept the older one because it worked fine. It’s a simple binary repo with nothing fancy.

Thanks for the help!


Error Getting Index file
#2

Logcat giving any clue?


#3

Unfortunately not, CatLog seems to not work at all and aLogcat or running logcat from the terminal gives nothing about F-Droid. Don’t have a computer I could use adb with near me for some time in the near future.
Though I may be doing something wrong, I haven’t tried to check the logs directly from Android before.


#4

Hi @Naur, are you able to pin down which version of F-Droid was the last to work with it? You can download past versions from the browser at https://f-droid.org/packages/org.fdroid.fdroid/. Although the website is not up to date with 1.0-alpha0, you should also be able to install that version via the F-Droid client itself.

The big ones to test would be 0.102.3, 0.104, and 1.0-alpha0. If all of them fail to work (after a clean install) then it is likely a problem with fdroidserver and we can further diagnose the problem.


#5

I always used the latest version of the F-Droid client available so I’m guessing it was the same version but I can try the earlier versions.


#6