Pipeline error "access denied or repository not exported: /x264.git"

Hi there,
I’m trying to include my app into FDroid and already burned all CI/CD minutes of january because I could not get my errors fixed. Finally I have all error with the app itself fixed, but the build process failes at the lint stage.

I get the following error:

srclibs/x264.yml:
fatal: remote error: access denied or repository not exported: /x264.git

Found 181 errors.
Cleaning up project directory and file based variables
ERROR: Job failed: exit code 1

How can I fix this? Thank you very much in advance, I’m pretty much new to FDroid and have some trouble getting it to work.

Metadata file: https://pastebin.com/R033wi0u

Could you share your full metadata file?

1 Like

Sure! I updated the question

I meant your metadata file, not the full build log :slight_smile:

1 Like

Oh, I’m sorry. I changed it :slight_smile:

Hmm, I’m not seeing anything obviously wrong. I think the build system may not be recognizing the file to build and trying to build something else that is going wrong.

Can you make a merge request on https://gitlab.com/fdroid/fdroiddata/-/merge_requests, so we can see how it goes when trying to submit it? Perhaps the build will work better then.

1 Like

There it is https://gitlab.com/BlazeCodeDev/fdroiddata/-/merge_requests/2

@BlazeCodeDev

If you do it in the F-Droid Data repo…it gets access to F-Droid CI time…

1 Like
Cloning into 'x264'...
fatal: repository 'https://git.videolan.org/x264/' not found

So maybe the repo has moved to https://code.videolan.org/videolan/x264 :slight_smile:

Fixed: https://gitlab.com/fdroid/fdroiddata/-/commit/cc9c7a6d2da48beee0f9ab22abc0081572dccb46

1 Like

Thank you very much. This solved this issue. It now however shows a different one and I have no idea what to do. It seems to be some kind of formatting issue.

Error: https://pastebin.com/7Jf2zdpp
Metadata: https://pastebin.com/QShxgcRG

fdroid rewritemeta --verbose com.blazecode.tsviewer :slight_smile:

See that lines are blank and don’t have spaces instead.

Fix spaces in the sudo section as explained by the error :slight_smile:

Why did you use x264 srclib before but now the recipe does not?

1 Like

Building now…will see…

1 Like

Builds fine, and starts, can’t test as expected

Shall I open a MR or would you?

AntiFeatures:
  - NonFreeNet
Categories:
  - Connectivity
  - Internet
License: MIT
AuthorName: BlazeCodeDev
AuthorEmail: info@blazecodeapps.com
AuthorWebSite: https://blazecodeapps.com/
WebSite: https://blazecodeapps.com/
SourceCode: https://blazecodeapps.com
IssueTracker: https://github.com/BlazeCodeDev/TSViewer/issues

AutoName: TSViewer

RepoType: git
Repo: https://github.com/BlazeCodeDev/TSViewer

Builds:
  - versionName: '1.1'
    versionCode: 2
    commit: 1ee132490b609dd72cf62b025ab62bc893d0671b
    subdir: app
    sudo:
      - apt-get update || apt-get update
      - apt-get install -y openjdk-11-jdk-headless
      - update-alternatives --auto java
    gradle:
      - yes

AutoUpdateMode: Version v%v
UpdateCheckMode: Tags
CurrentVersion: '1.1'
CurrentVersionCode: 2
1 Like

Thank you very much, I’m surprised by how supportive this community is. I’m used to the normal harsh tone of StackOverflow. This is a nice surprise!

It now runs and I just merged it: https://gitlab.com/fdroid/fdroiddata/-/merge_requests/10574
Again, thank you very much!

I literally gave you the correct recipe, why didn’t you use that directly? :slight_smile:

Now you got me confused. I used your suggested metadata, is that what you mean by recipe?

I saw more than one commit in the MergeRequest, I guess you did that eventually :slight_smile:

Oh, yeah. I first tried to adjust the spacing myself and then I replaced it all with your version.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.