Phantom Update ..."15 characters"

So… I’ve got a weird one for ya. I tried to install the GUI version of Stone Soup (not the ASCII version), and it failed. I said “Aw!” and moved on.

That was about a week ago. Today, for the third time since I installed it, I’ve gotten a notice from F-driod saying “1 Update: Dungeon Crawl Stone Soup is ready to install.” When I scratch my head and go check it, there’s nothing there to update. That’s odd enough all by itself, but the real kicker is that neither version of Stone Soup appears to have been updated for months!

I’m wondering if there’s some crossover between the GUI version and the ASCII version internally in F-droid’s database that’s not functioning as expected?? I dunno, I can’t see that stuff, so I’ll leave it up to you guys to sort. Do kindly let me know what the issue is, because I would like to check out the GUI version of the game, if it is actually functional. :slight_smile:

p.s. The title says “15 characters”, because the website told me that the title has to be at least 15 characters. :smiley:

Device? Android version? F-Droid Client version? Can you update to latest 1.19 (expand Versions) and retest?

Moto G Stylus, Android 11, 1.18.0

Huh… why didn’t it tell me to update F-droid to 1.19?? I can see 1.19.0, but 1.18.0 says “Installed Suggested”. Not sure what that’s about. I’ll update it manually.

…and yes indeed, that solved the problem of the game not installing. Now then… why was it telling me that there were updates, when there were not?? Was that a symptom of a version mismatch?

Also, there is the new question, why didn’t the update system tell me to update to 1.19.0??

Thank you for your help!

Odd things are odd :slight_smile: keep an eye on it in the future