Package installer keep stopping

Everything was working normally until I updated the app. After that I wanted to update Librera but it didn’t work instead it showed: Package installer keep not working. I tried to install another app and the same thing appears. The same thing happened to someone

View Summary:
java.lang.RuntimeException: Unable to start activity ComponentInfo{com.miui.packageinstaller/com.miui.packageInstaller.InstallStart}: java.lang.NullPointerException: Parameter specified as non-null is null: method j8.i.f, parameter uri
at Source:911)
at Source:77)
at Source:79)
at Source:77)
at Source:76)
at$H.handleMessage(Unknown Source:172)
at android.os.Handler.dispatchMessage(Unknown Source:19)
at android.os.Looper.loopOnce(Unknown Source:182)
at android.os.Looper.loop(Unknown Source:82)
at Source:123)
at java.lang.reflect.Method.invoke(Native Method)
at$ Source:11)
at Source:312)
Caused by: java.lang.NullPointerException: Parameter specified as non-null is null: method j8.i.f, parameter uri
at p5.i.d(Unknown Source:7)
at com.miui.packageInstaller.InstallStart.g(Unknown Source:17)
at com.miui.packageInstaller.InstallStart.onCreate(Unknown Source:467)
at Source:127)
at Source:1)
at Source:3)
at Source:636)
… 12 more

Did you try to debloat your device? to disable or uninstall packages?

I cleared the cache of Package Installer, reinstalled the system, but none of that worked. I install f-droid, update the repositories and then update f-droid. I try to install any app but it always comes out: Package installer keeps stopping

But looking at your error details, it looks like some issue with an update/upgrade upon not from F-Droid. Did you check on MI forums? Suggest you raise a query/issue there.

Solution: install f-droid but do not update it. another way is not to update to But I don’t understand, I use and before updating f-droid everything was fine

Can anyone use ADB and get a logcat of the moment you try to install a package so maybe we can see the actual error? Or confirm that it’s the same as the linked forum.

Also, what is the last F-Droid Client version that installs other apps fine?

eg. do test 1.18.0:




The version in which it works is 1.17.0 I am going to investigate what adb is

It seems like a bug in the package installer app. Try clearing its cache or updating the system software, and restart your device.