No notifications No sound from Alarm Apps

Hey,
Alarm Apps i get via F-droid don`t ring. I tried to give them every permission they can get.i also accepted interrupts. But no notification showed up, when i set up an alarm.
I tried “simple clock”, “Alarmio”, “clock+”, “Alarm Klock”.
After downloading simple clock from google play, it works out of the box.

can someone help me?

Can you check your battery settings? You might have some sort of battery saving feature that are killing apps running in the background. You might have to whitelist these alarm apps.

https://dontkillmyapp.com has some tricks, basically your OEM is at fault.

What device and Android version?

I had this issue too after my phone updated to Android 10. I had Simple Clock installed but no Alarms anymore. I tried more Alarm apps on F-Droid but still same issue. Then I saw this post https://github.com/SimpleMobileTools/Simple-Clock/issues/160#issue-542726042
Looks like all the Alarm apps need to be updated for Android 10. Simple Clock has fix this issue already with updated versions on Github and Google Play Store but it hasn’t updated on F-Droid yet.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.