No files found for URL all other packages had no errors

Dear community

I followed this manual and ended up with the following output of those 2 screenshots. I did everything on the server since the beginning so I only left out the part ’ Syncing to a remote’

Can someone help me by figuring out, what is wrong here?

Thank you so much.

@Izzy ^^^ ping

@Licaon_Kter have you an idea, what could be wrong?

I’m not hosting so not sure

Can you download the files from the URL? https://path/fdroid/repo/linkto.apk ?

Oh, ähm… No!
But I’ve put an index.html file inside fdroid/repo and it shows up.

First of all, there should not be an index as file should be usable via the Client not in a browser.

That aside, you mean, your APKs from the folder are not downloadable from a browser?

Ok, thanks. Yes, I can’t download the apk file. When I want to download the apk via link like you mentioned, nothing can be found.
But the apk file with this name is in the right directory on that server, reachable over the domain I tried. Strange…

My crystal ball is out for polish, so I have to guess without it:

  • screenshots from your directory structure look correct
  • client saying “ungeprüft” (unverified) means it didn’t yet get an index

The address is not visible in your screenshot from the client as you “sanitized” it. So let me assume the full URL would read In a web browser on your Android device (the one the client screenshot is from), please write in your address bar (after correcting the assumed part). Does that throw an error? If so, what error?

Thank you for your reply. When I add it as an repo link inside fdroid, (with my adjusted domain) it throws the exact same error as before, just with the domain I tried right now.

Edit: I also tested it with the index-v1.json url. Same.

That was not what I asked you to do. I cannot help you without clear details, sorry. If you can provide the full URL (without parts blackened/sanitized) I could take a look myself.

Sry. There is a ‘not found’ error. I’ve sent you the complete url as a private message.

Yupp, good idea to deal with it that way. Answered there already: that’s an issue with the setup of the web server (gives 404 all the way up until only https://<serverName>/ is left). Further debugging needs server access, so you need to do that with someone who has that. Your repo setup is probably fine.

1 Like

After a night of sleep and syncing again with the fdroid client, there was no error this morning. It works now. Juhuuu xD!

All of you, thank you so much for your help and your time. I am so happy it works now.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.