No connection in shelter

Hi,
i’m trying to install whatsapp inside shelter but i’m not able to make internet working there.
I’m using afwall and i enabled the app inside shelter to connect only behind a VPN but it’s not working. I also tried with fennec but nothing. If i completely disable afwall then connection works but my goal is to route only through the vpn.
What am i missing?
Thank you.

Hi, try to report this to the app developer: https://github.com/PeterCxy/Shelter/issues

Also keep in mind that VPNs/firewall might not work ok in both normal profile and the shelter one.

I noticed the problem is about the VPN because if i enable only wifi on afwall it works.
I will report the issue on github then.

Hi!
I abhor anything facebook, but I was in a similar situation with skype for business that is almost as bad (and most likely uses facebook trackers because M$ are being morons).

I managed to get it to work using this steps:

  • Install Skype
  • Add it to shelter’s work profile (but to not remove it from your regular apps)
  • AFWall+ Preferences -> Experimental -> Dual Apps Support
  • Get AFWall+ to refresh apps list
  • Now you should have an entry “AppName” and “AppName (M)” for all apps in your work profile
  • Allow “Whatsapp (M)” or so.
  • Apply

For me this worked then, however it stopped working once I uninstalled Skype and kept it only in the work profile.
For me this was not satisfactory so now I have to do without. However if that is fine with you (have a firewalled, not set up whatsapp in your regular profile), you can give it a try.

Alternatively it might just work to change firewall behaviour from blacklisting to whitelisting.

Please let me know if this works!

If at all, I think you would need to raise an issue with AFWall+ not Shelter.

Thanks for your reply.
I actually did the process you described, but the problem seems is regarding the VPN system itself. If i enable let’s say Fennec(M) on wifi only through AFWall+ it works fine, but whenever i enable only the VPN inside AFWall nternet is not working anymore inside the sheltered app (M). It’s like if the whole vpn system is not working inside Shelter at all. Everything works fine on the main profile.
Also, if i disable AFWall but i’m still under VPN, sheltered apps connect outside it. Maybe there is any setting to allow work profile (sheltered apps) to allow VPN connection or something like that?

P.S. Im on LineageOS 16

Hi!
Sorry it took me a few days to reply. I tested whether VPN and work profiles would work at all. I have to say I am impressed how well it worked.
Using shelter and OpenVPN for Android (with different configs and different exit point IPs) as well as browsers in both ordinary profile as work profile I did the following:

  • Clone browser and openvpn to work profile
    • import openvpn config #1 into work profile
    • allow openvpn and browser in AFWall+ (for work profile)
  • VPN #2 in ordinary profile and no VPN in work profile worked for me
    • home IP (non-VPNed) in work profile browser
    • VPN IP #2 in ordinary browser
  • VPN #1 in work profile and no VPN in ordinary profile
    • VPN IP #1 and access to internet in work profile
    • home IP in ordinary apps
    • messages that says that VPN is activated in work profile, when I pull down status bar
  • VPN #1 in work profile and VPN #2 in ordinary profile
    • IPs as expected
    • Message “Device connected to VPNs”

So I guess you might not have added the VPN app to shelter.

Again, I am impressed and quite happy I tried this :slight_smile:

P.S.: I have got a fairly recent LOS 16…

Mastodon