No apps available

I just installed F-Droid, the first time I opened it, each tab was blank and searching yielded no results. I restarted it and was able to browse some apps, didn’t install anything at the time, thinking everything was now sorted and working. I try to use it again and… nothing again. I have tried clearing cache and restarting my phone.

My phone is running android although it is quite unusual: it is a Kyocera Gratina 4G KYF31. It does not have a touch screen. This made me wonder if some apps are being filtered because I can’t use them without a touch screen? But i did try unchecking the option specific to that in the settings.

Also! Is there a way to make the F-Droid interface work better without touch controls? It isn’t ideal to navigate like this as I can’t scroll down to see app descriptions-

On the first install you have to pull to refresh.

BUT there is a weird bug where sometime later you’ll open F-Droid and it’ll be blank again and will have to refresh again.

After those first two times it should be fine.

if some apps are being filtered

Is possible, but if there were still no apps after enabling the option to show incompatible apps it was likely the above quirk. And you did mention seeing apps beforehand.

1 Like

By pull to refresh, do you mean dragging down like refreshing an email app? I don’t think its possible for me to do that because I don’t have a touch screen…

I don’t think its possible for me to do that because I don’t have a touch screen…

I managed to get it to work! On the slim chance anyone else is using this same device:
Press and hold F3 (the pointer button), slide your finger up to move the pointer, and slide it into the top edge of the screen, the same as scrolling. I assume pressing page up on a keyboard or scrolling up some other way would work too.


it happens all the time. i use to uninstall an reinstall fdroid.
this is the MAIN reason why people test fdroid and then remove it.

With 1.13.1? Which Android version? Which device? What type of network? Using VPN or Tor?

Just saying “happens all the time” means nothing, c’mon.

1 Like

happens on my cheap smartphone Alcatel X1 which has Androig 9 go version.

happens on my Android Studio Nexus 4 with Android 25 emulator.

happens on my bluestacks 5.1 emulator.

happens on my mothers Samsung Galaxy, too.

not using vpn or tor on these devices.

i AM serious. removed and installed froid client so often.

being interested in fdroid success as i have stuff there too.


Great, now, can you capture some logs at that moment when you pull-to-refresh and it refuses to update? Eg. try with 1.14-alpha2

1.13.1 seems to have fixed prob, did not occur anymore

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.