Mobile hotspot limit override

Is there a setup to override the carrier’s limit for wifi tethering?

1 Like

I guess that not without root.

Root is available. You know how to?

Maybe root is not even needed try with
https://f-droid.org/en/packages/be.mygod.vpnhotspot.foss/ (read the docs)
&
NetGuard | F-Droid - Free and Open Source Android App Repository (needed for a local VPN, also a great firewall in itself)

1 Like

Thank you for suggestions. First app wants root. And already using Netguard as a firewall for long time. I did suspect there should be a way to fool the stock tethering service with it but couldn’t figure it out. Can you guide me on how to implement it for the purpose in subject please?

Netguard is a great app, but some settings are not clear to me, I simply don’t understand what is subnet routing and allow lan access and what they do?

What limit are you talking about? That tethering can be enabled or that it works at all?

My cell plan has unlimited data, but hotspot tethering is limited to 5gb/month. And when i connect laptop to phine’s hotspot it cant go online. So i am wondering how the cell provider knows that im in hotspot mode and if rhere is a way around it. After that 5gb point, phone’s unlimited data still works fine. Only the hotspot is not providing internet to laptop.

1 Like

you said you have root…so, what’s the issue?

Usually mobile hotspot traffic origin is determined by a software on mobile network provider side. They fingerprint the data and thus know the origin by a certain chance.

What you can try is to use an intercepting proxy like mitmproxy on the phone and use that from your computer. This could change the connection fingerprint.

@free-j

The common one is the phone will directly tag the tethering traffic by routing it using a different APN config.
Or check the carrier config and completely disable/block the in-built tethering feature.

Kind of sad even after “net neutrality” that we have such silly limits imposed.

2 Likes

I have netguard/orbot network srtup on phone but while tetheting it never affected the client laptop it was not connected to web through TOR i checked. Laptop has a vpn on it though doesn’t it help to trick the fingerprinting? Or maybe client’s mac should be randomized? And how does the carrier fingerprint? During research on android’s firewalls many times i’ve seen statements that tethered traffic is bypassing phone’s vpn is that true? If so why both netguard and orbot have a setting to tether?

I tried to edit the APN all lines in it are greyedout. And creating a new APN doesn’t work - after i save it it doesn’t appear in the list of APNs.

Look for program written by Guy named Jesusfreak. I’m being dead serious. At 50 I can’t name the program in my head but I can see it and even give a block of instruction on how to work with it… it’ll happen to you too lol. Anyway that’s enough information for you to find the program. When sharing the Wi-Fi it links you via the Bluetooth and that way it doesn’t keep track of you and they can’t find you. Plus it will give you another way to ask the old school people without raising alarm.

Search reaults on this have nothing to do with question in subject.

so i figured after hours/days tweaking,has ro do with the ttl, fixedit on the client device and that’s it. easy when the client run windows now gotta figure out how to edit ttl of other client like iphone tv etc.

I know on a non rooted Samsung Galaxy S5 phone, you could install an app named process terminator or something like that. Then you could tell it to prevent a certain process from running on the phone. This removed hotspot limitations as that process was what prevented the hotspot from working. I suspect if you get some other process terminator app and end the right process, you could do the same on any phone.

man that certain process name is the key what is it called please?

If rooted try changjng the TTL, TTL Editor | F-Droid - Free and Open Source Android App Repository

Usually carriers use other methods these days than just checking time to live but iv noticed for some it is still that simple.

simple edit of ttl to 65 on tethered client device(win 10) solved the issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.