Mindustry has not been updated for a long time

The last update (v104) was two years ago.
As of now the stable version is v126.2 and the pre-alpha version is v137. Something seems to have gone wrong.

Known issue, it needs Java 14 or 16 or 17 and (until the server is updated) we don’t have this dependency.

Out of curiosity, what is blocking this java update on server? Some tool incompatibility, lack of maintainers, …?

We are on Debian Stretch currently and java 17 is not packaged.

1 Like