Librera updates messed up rendering

Librera Reader last two versions in @fdroidorg messed up rendering
Version 8.8.40-fdroid (5098)
Version 8.8.30-fdroid (4895)

The last version that works fine is:
Version 8.8.15-fdroid (4865)
#Librera #FDroid

Try to downgrade but failed. Uninstall and reinstalled worked.

What version is your device?

Android 10


Try to go to Library, left menu, Engine, select MuPDF_1.11, restart app, retest?!

I have tried changing the engine with both the newer and the old versions of the app cannot make 1.11 stick. The older version works fine with 1.21.1. Let me do a backup and update to try to get a screenshot.

I originally went
Version 8.8.15-fdroid (4865) to Version 8.8.30-fdroid (4895) to Version 8.8.40-fdroid (5098)
Now I went
Version 8.8.15-fdroid (4865) to Version 8.8.40-fdroid (5098)
and the issue persists in the newer versions.

Also the description in f-droid for librera states:
“For better security, the F-Droid version, is based on the latest MuPDF 1.16.1 and does not require access to the Internet.”
But 1.16.1 is not even an option now.

We’re past that as 21>16 :slight_smile:

Anyway, what you didn’t report is that/if upstream APKs work fine or not: Release 8.8.46 · foobnix/LibreraReader · GitHub ?

Because if they have the same issue, better report it to them: Issues · foobnix/LibreraReader · GitHub instead

You are totally right, don’t know why I didn’t go to their GitHub first.
Now I did and release 8.8.68 fixes the issue. Hopefully will be in f-droid repository soon.
Thank you.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.