Issues with updates from F-Droid

Hello Licaon_kter and Fdroid team. I have been an Fdroid user and fan for many years on many devices. I always root my devices and completely dispose of all google apps and replace with open source apps.
Fdroid is always the first app I install as I do not like google play nor any google software. My current device is oneplus 8t running android 11.
For some reason my Fdroid decided to stop updating itself. It also will not update any of my apks. I am currently using 1.20.0 alpha0. I am not certain but I think the last version that updated properly was 1.17 or earlier.
When I began experiencing this issue, I tried stopping Fdroid and clearing cache and data but no success. Then I updated Fdroid to the newest release from the fdroid website but no success. Then I would wait for each new release and update again but still no success.
I do not know what else to try. Thank you

1 Like

this is the latest version, yes

Define “properly”? Did you enable autoupdates etc in Settings? Did you slide both Wi-Fi and mobile data all the way to the right to Always? Did you except F-Droid from Android Battery optimisations?

Are you saying the mobile setting should always be to the right, and if so, why? Mine is set to the midpoint and appears to work well in that position.

yes and no, also you don’t have an issue :slight_smile: right?

yes, sometimes we see pics/icons not being downloaded on mobile data IF not set to Always

I’m trying to establish a pattern here, to find out what happened

No, I have no problem with updates. I’m just trying to understand the reasoning behind the recommendation to set the slider to the right. It seems it is only necessary if one has a problem with updates. Correct?

Who knows, lets have all to ON, test, get some info.

Originally I did not have auto updates enabled but after many failures in my quest to solve the issue, I enabled auto updates but no success. I normally manually update Fdroid and each app but I do allow Fdroid to check for and notify me when updates are available.
When I attempt to update Fdroid or one of my apps, it says downloading, then after download is complete it says installing but never completes installation.
It’s also the same when I try to install new apps.

I have WiFi and mobile data enabled slid all the way to the right and battery optimization is disabled

you can reproduce this with latest 1.20-alpha?

Yes sir. The exact same thing happens with 1.20 alpha. Also I am seeing no error messages when this occurs. I do not know how to produce a logcat. Would it help?

yes, would help

install ADB: https://www.xda-developers.com/install-adb-windows-macos-linux/

get some logs: https://www.xda-developers.com/how-to-take-logs-android/#system-logs from the moment it happens