Issues with F-Droid client app

Lately I’ve started to get two errors when trying to update apps through the F-Droid app.

The first issue comes when I refresh repositories by pulling down and then letting go of the “Latest” page.

The message I get is:


f-droid.org/en/packages/de.dennisgues.opentracks: Error getting F-Droid index file => null

All other repos didn't create errors.

I used to have Opentracks installed but removed it while back. I tried reinstalling it, which works fine but I still get the same message.

The second issue comes when I try to update certain apps. For the later version of the apps I get the following message when I click on update next to version.


The new version is signed with a different key to the old one. To install the new version, the old must be uninstalled first. Please do this and try again,,.

I’ve seen this for K-9 and Syncthing. I uninstalled K-9 but I still wasn’t able to install the latest version. Instead I had to install it from the Play Store. I just want to make sure there isn’t some other way to fix this since I will have to reconfigure a few things if I remove Syncthing.

Is there anything I can do to fix these two issues?

Not really a fix, but you can always use a browser to visit web pages for the apps, manually download the latest version, and install outside of the fdroid app. Then you would at least have the fdroid version instead of the playstore version.

Since you switched to the playstore version of K9 that would mean another pass through the uninstall/reinstall loop, but for syncthing (assuming your previous install was done through fdroid?) you should be able to just install manually over the top of your existing install.

Not an issue since Android only updates apps from the same signer, be it only Play or only F-Droid. As said above…uninstall/reinstall

Device? Android version? F-Droid Client version?