Installing F-Droid in a different Android profile

When i try to download fdroid on adifferent user on the same device I get the errorcode package invalid which is frustrating becouse its rendering the other user accounts useless

Android has a limitation for security reasons, it only allows you to install the very same version of an app for the other users.

I guess you’ve updated F-Droid, but the main blue button still serves older version 1.14.

Try to install latest 1.15.2: https://f-droid.org/repo/org.fdroid.fdroid_1015052.apk

ref: Bump F-Droid apk link to 1.15.2 (!823) · Merge requests · F-Droid / Website · GitLab

Sadly that didnt helped on my second account I have 2 fdroid apk one old one new neither of both work

In first profile, in F-Droid, go to Settings - About, which version do you have?

On both profiles version 1.15.2

Ok, let’s back off.

You have in first profile F-Droid 1.15.2 installed and working, right?

Now, when you try to install in the second one you get which error?

useful information

I get the error " App not installed as package appears to be invalid"

Not sure what’s the issue, just remove the APK and redownload https://f-droid.org/repo/org.fdroid.fdroid_1015052.apk also make sure F-Droid - About says 1.15.2

Else, do grab a logcat with ADB when this error occurs

Thanks a bunch! this apk worked from where are you knowing this direct link?

I already gave you the link before…you said IT DID NOT WORK ? ! ? ! ? !

From the app page: F-Droid | F-Droid - Free and Open Source Android App Repository scroll down to 1.15.2 and Download APK

With where you said that I just need the latest version I just downloaded it from https://f-droid.org/ you know the front page were the thing with the pjp signature is offered and that didnt worked but the link worked

Read post marked as solution again, I’ve literally said what the problem is, and how to solve it: use this apk because “I guess you’ve updated F-Droid, but the main blue button still serves older version 1.14.”

Oh im sorry

1 Like

Hello, I am using a Google Pixel 6 with Android 12 and GrapheneOS.

I’ve managed to install the APK previously in the past on one of my user profiles but it doesn’t work on any new profiles (or my original “Owner” profile).

I am unaware what was the original version of the APK when I installed F-Droid successfully on my Owner profile, it was early 2022 though, I believe I just clicked the main download button on the website.

I install the latest APK from f-droid.org from Vanadium and once installing the app, I get this message:

F-Droid

App not installed as package appears to be invalid.

I had tried to install older versions of the APK, including

  • org.fdroid.fdroid_1015051.apk
  • org.fdroid.fdroid_1015050.apk
  • org.fdroid.fdroid_1014050.apk

All of which arrive to the same error.

Any ideas on what I could do to remedy this?

@dizpocuacme read post #2 above