Installed privileged ZIP - phone won't boot

Hello,

I tried to install the privileged version of F-Droid via TWRP recovery - install zip. Unfortunately, now my phone will not boot anymore, the boot picture is displayed, but it won’t boot the system. I already wiped cache and dalvik cache, but this did not fix the system. Unfortunately, I did not create a system backup before trying to install the F-Droid zip file

I used the file org.fdroid.froid.privileged.ota_2090.zip, which might have been the wrong one for ZIP install(?)

What is the fastest way to un-install the privileged zip? Any file / directory to delete / rename from TWRP?

I can also install the original rom files again. Would re-flashing the system image be enough? The device is a BQ Aquaris X5 Plus.

Any help would be appreciated.

Mulmor

Hi @Mulmor,
Welcome to the F-Droid forum. :slight_smile:
I’m not entirely sure what could have went wrong - you seem to have used the right file and did the right operation with TWRP - but yes, I would also try reinstalling the OS.
If you flash the same version that was already installed and everything goes wrong you might not even loose any data.
If that works then of course I’d make a backup and try flashing the privileged extension again. Maybe make sure you have the latest TWRP installed first.

1 Like

Hi paulakreuzer,

I did flash original system.img and boot.img (just to besure). Device boots up again, looks like everything is working as it should. Will try again, when I have more time for a proper backup beforehand.

I do not have TWRP installed, I just booted into the latest TWRP image via fastboot.

Greetings
Mulmor

2 Likes

This is the first report I’ve seen of Privileged Extension breaking booting, but anything is possible. Can you tell us which ROM the device is running, and which TWRP version?

A Magisk systemless module could help ; btw, on latest Pie, adding a /system/etc/sysconfig/fdroid.xml could (?) help:

    <app-link package="org.fdroid.fdroid" />
    <system-user-whitelisted-app package="org.fdroid.fdroid.privileged" />
    <hidden-api-whitelisted-app package="org.fdroid.fdroid.privileged" />

last line should cover missing aosp platform certificate/signature (?) https://android.googlesource.com/platform/frameworks/base/+/master/data/etc/hiddenapi-package-whitelist.xml#19

Hi Hans,

I used the latest official update 2.7.0_20181002-1711 from BQ (via OTA) for the Aquaris X5 Plus. It is available as a download from their official site:
https://www.bq.com/en/support/aquaris-x5-plus/support-sheet
It contains Android 7.1.1 with security patches from september 2018, kernel version 3.10.84-g94447b2 .

Greetings

Hi oF2pks,

I’m not sure what exactly I’m supposed to do, but I will not install Magisk just to get another software running.

Greetings

On Nougat (or older) , within twrp, you just need a basic copy file:

  • option: mount /system
  • copy privilegedFdroid.apk into /system/priv-app/
  • reboot

(On Oreo (or newer) need to settle multiples : https://source.android.com/devices/tech/config/perms-whitelist)

If you need certified stuff (google pay…) Magisk is only way to hide your /system modifications (like Adaway).

1 Like

@Mulmor you should be able to reflash that system update to restore your /system partition back to the pre-PrIvileged Extension state without wiping your data.

@hans
As I already wrote, the phone is working again after re-flashing /system with the original image. I have currently no plans to try again. If I do I will post an update whether it works or whether it breaks the system again.
Sorry for the late reply, I did not notice the conversation continued.

@Mulmor you should be able to reflash that system update to restore your /system partition back to the pre-PrIvileged Extension state without wiping your data.

@ [oF2pks] I might try to install the privilegedFdroid.apk directly, the instructions you gave are indeed easy to follow.

Greetings
Mulmor

P.S.: Concerning Magisk: I tried to report / fix a problem when installing F-Droid as one isolated system modification. Installing far-reaching low level system modifications is another subject (and decision) entirely, I might install Magisk in the future (among other things for the hiding reasons you mentioned), but not at the moment.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Mastodon