Install Failed Due To Unknown Error

Hi, I have F-Droid installed on my Samsung Galaxy S7. I am trying to update two apps (including F-Droid itself). The download appears to be working; however, I am getting an error message saying ‘Failed to install due to an unkown error’, for both the apps I am trying to update.

I have checked the settings: F-Droid has permission to access storage and permission to install unknown apps. My storage space is a little low, but I have ~400 MB free, which I thought should be sufficient. I have tried rebooting the phone and I get the exact same error.

Any ideas what might be causing this and what else I can try?

1 Like

Yes, space might be the issue… sometimes it actually notifies you about that.

1 Like

@Licaon_Kter I cleared off some data, so I now have ~2GB free. However, when trying to install an update it still seems to be failing. A couple of times I saw a different error message: “Blocked by your IT admin”, but now it seems to have reverted to just “Install failed due to an unknown error”. I have checked the settings again and ‘install unknown apps’ for F-Droid is set to ‘allowed’. Any ideas?

This is a Work Device? Which app did you use to install F-Droid itself?

@Licaon_Kter no, it’s my personal phone. Although, I have a ‘workspace’ installed on it where I do have some apps installed relating to my employer. I had to do that to be able to install a soft token I needed to access the company VPN. So, maybe that could be interfering somehow?

I don’t exactly recall where I installed F-Droid from. I think it was from the website?

Through which app? Browser or filemanager?

@Licaon_Kter I think it was through a browser. I typically use Icecat Mobile.

Can you get 1.10-alpha0 ( ) then clean App DATA in Settings - Apps and retry?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.