I have installed app manager from fdroid which is draining lot of battery and unable to uninstall

How to uninstall app manager latest version

I had installed this App manager from our fdroid

App Manager - Android package manager
App Manager - Android package manager (A full-featured open source package manager for android.) - https://f-droid.org/packages/io.github.muntashirakon.AppManager

app from my device
(Non rooted)

Android Settings - Apps - App Manager -> uninstall?

I have tried everything,

  1. My samsung A6 is not rooted
  2. This app dont have admin rights
  3. I can clear data, change ops permissions of this app but only cant uninstall the app.
    App is behaiving as system app

adb uninstall appid via an USB cable from a PC?

I havent tried using USB ADB method yet, but my question is how any user app would behave like system app without any administative previlileges ?
Afterall its a application installed by the user on non rooted stock os!

As the app developer said, it’s an issue with your ROM, I guess too.

If the problem is only battery drainage, you can do Android Settings - Apps - App Manager -> -> App Manager -> Force stop.

(my own app SuperFreezZ automates this process but you probably don’t need it just for one app and I don’t know if you even want to install any other app now)

You are not getting my point clearly.
I have installed one app named app manager from fdroid (i have attached screenshot as well)
My mobile isnt rooted though this app manager( installed from fdroid) is making trouble for me …
As its a user installed app(by me)
It could be removed by
Settings -apps- appname -uninstall
But when i tried to uninstall The app it wont get deleted from my phone (normally it should be removed from phone)
Anothor possibility is there if any app has administative rights (which can be granted by user, but this app dont have any admin rights)
Second posibilty is if my phone is rooted and this app instlled as system app but my phone is not rooted ever.
So, my question was is there posibility remaining ?
Which might i havnt tried.

Bro, its not a system app, its just a user app installed on non rooted device.
It should be removed easily from mobile phone.
I am questioning about apps behaviour
How any user app behave like system app
Is there any setting left to disabled by me ?

Please check if you can uninstall other apps. The problem you are experiencing is not that the package installer does not allow uninstalling (like it would be with system apps or device admin) but it crashes when trying to uninstall.

Some ideas what could cause this:

  • You use an app locker
  • You changed the permissions of some system apps
  • You disabled system apps (using the app manager?)
  • You use an overlay app
1 Like

As you say, we agree, this should not normally happen. Since this happens only on your ROM, then…

Hi bytehamster,

I can uninstall any user app easily but only this app cannot be deleted

Absolutly right, but if my phone is not rooted then how this app could become system app ?
Its a 2 year old phone but i havent tried even once.
And my issue isnt that app is consuming lot of battery but, how could any user app resist itself from uninstalling ?

It can’t.

You manually granted some sort of administrative permission to have access to other apps usage. Even more, apps cannot request this permission directly, so the app probably asked you that and sent you to a settings panel where you did allow that behaviour (the ability to manage your device/ your usage)

Remove the app from the list of apps that can manage usage / can admin your device / are whitelisted as accesibility apps and you will be able to uninstall it.

Exactly pazos,
But unfortunetly this app dont has any rights
I have checked all those possibilities
Either the developer found a to made his app delete resistant or
We might have malware in our repository.
Infact i have mailed the developer muntashir al islam about this
Unfortunrtly he is a senior developer he might late to reply.
I am afraid to reset my phone because its lockdown and there wont be help available from IT team of my company to install and register corporate settings.

@Mahem:

declared permission: https://github.com/MuntashirAkon/AppManager/blob/master/app/src/main/AndroidManifest.xml#L31

prompt the user for the permission:

Please, don’t spread FUD. This app is a piece of art for both power users and developers. It is entirely opensource so any suspicious behaviour you might think it has can be easily debunked.

Edit: if you don’t find the settings panel to manage these kind of apps you can launch it from adb using adb shell am start -a android.settings.USAGE_ACCESS_SETTINGS

2 Likes
  • There are some cases where the uninstall button in F-Droid itself doesn’t work.
  • You should always be able to uninstall an app from the global Settings app.
  • There is the very very rare case where Android breaks and manages to set incorrect permissions for an apps files. This can result in an app being unable to be removed or installed again. I’ve only ever seen it twice over the years.
1 Like

I found a simple solution on the issue. When another app was tasks was also behaving like app manager
I freezed both apps and tried uninstalling from system it worked well.