I cannot download apps from f-droid site

Dear All:
Since I tried to download the Librera app from the F-Droid site. I can’t download any other app from this place. It appears the Android message: “Not installed”.
But I’m surprised if I can download apps from Google Play wihtout any problem.
I have tried the following solutions I found in some internet pages:
1st. I´ve Turnned-off Google Play Protect.
2nd. I´ve resetted the App Preferences in the Android settings menu.
3rd. I have putted the F-Droid platform as a valid platform to download apps.
4th. I sent a message to the develloper, and he hasn´t still answered my mail.
… and the problem hasn´t been solved.
Please. Do you know how to solve the “not installed” Android problem to continue downloading from F-Droid platform?
Thanks in advance.

So you’ve downloaded Fdroid.APK…tried to install it and it worked?

I have been having the same issue for that last few months, but only when I already have the app installed from another source.

If I try to install from an app from an APK file that I have already installed from either Google Play or F-Droid, I get the “not installed” error.

For example, I had NewPipe installed from F-Droid and then attempted to install a newer version from a downloaded APK (from github). I had to uninstall NewPipe first in order to not get the “not installed” error when installing the NewPipe APK.

I have experienced this on two different phones. It has only started happening in the last two months or so.

Oh, that one? Well that’s the way Android works, for security reasons, you can only update apps signed by the same signature, be it from Play, the developer or F-Droid.

So no, you can’t update NewPipe from F-Droid with the APK from Github, or some app from Play with the one from F-Droid.

F-Droid was installed in my device some months ago and I have downloaded some apps without problems from F-Droid site (Exodus privacý, ClassicShark3xodus, Silence, Share to computer, Audio recorder, …)

Try to update your index, pull to refresh…

It is not the scenario I have. The app I tried download, I´m very sure it wasn´t installed in my device before download the new one.
Thanks for your support.

Yesterday night, I see in the F-Droid settings, It was switch-on, the functionallity: To use Tor , in the section dedicated of Proxi.
I switched-off this functionallity and the problem was solved.
Many thanks to everyone for your support.

Thanks for your support. The problem has been solved (see bellow).
Anyway, I´d like to know what it means your proposal:
“Try to update your index, pull to refresh…”
I´m only a user level Android amateur.
Thanks for your support.

Other than with Play Store, F-Droid doesn’t “phone home” for each action (search, browsing apps, opening their details page) you take. Instead, it downloads the index of all available apps to the device – and then you could even cut your network connection and still be able to browse, search etc. Just to install/update apps you’d of course need to turn network back on.

Now, to stay up-to-date, from time to time you need to update that index. By default, this should happen automatically once a day while you’re connected to WiFi. But that sometimes fails. So to manually update the index, you “pull to refresh” – i.e. swipe your finger down from the upper area of the screen. This immediately triggers the check (and download) for index updates.

1 Like

Did you install micro G?

What has microG to do with it?

Thanks Izzy for your support. The problem has been solved. It was a problem of F-Droid configuration on my mobile (it was witch-on to use Tor).

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.