How to use GPS on custom rom without gapps?

I use phone with custom rom LineageOS but without GApps and use only Fdroid.
So far I had no need for a location, but now need I have installed the map turned on the location in the phone and cannot locate me.

What is the solution?

Install DivestOS instead of LineageOS, if your device is supported.

Not recommended: There was a Zip to add only location services part of microG, available for sideload when installing LineageOS (or other), but it stopped being updated last I looked.

Not recommended: You can also install microG-LineageOS (or other ROM with microG) and turn off all except location services in microG settings.

Which phone are you using? Which map app?

I’m using LineageOS 18.1 without GApps (and without MicroG) and GPS works as expected. When I ask the map app OsmAnd to find my location it manages to locate me exactly in a few seconds.

Edit: as far as I can tell, GApps and MicroG have nothing to do with GPS. Only non-GPS location services (nearby cell towers, etc.) use GApps. I’m not an expert though, so perhaps someone else knows better.

Edit2: GPS can have issues when you are indoors. Try stepping outside. :slightly_smiling_face:

2 Likes

“gps only” works fine too, a bit slower since it doesn’t cache old location data.

But a Custom ROM with https://f-droid.org/en/packages/org.fitchfamily.android.dejavu/ works a bit better

I add https://f-droid.org/en/packages/org.gfd.gsmlocation/ and https://f-droid.org/en/packages/org.openbmap.unifiedNlp/ and https://f-droid.org/en/packages/org.fitchfamily.android.wifi_backend/ hoping they magically help :slight_smile:

I have Xiaomi Redmi Note 7 with LineageOS 17.1
I will try your solutions to see if there are any changes, Maybe this custom rom has some problem but I didn’t find it on forum. I tried several map apps.

Fun fact: Before this I had a Xiaomi redmi note 4x with LineageOS 15.1, i am from the Balkans and the gps worked but it would take more time to find my location (just outside) but when i was in the EU (luxembourg, germany) the gps would find my location quickly

Not sure about expert, but I built many custom roms for phones. GPS is not tied to Gapps, microG or otherwise.
Some apps may require Gapps to work, but any GPS only app should work fine. I use Trekarta and opentopomaps and satstat without issue and I have no gapps or microG on my phone.

You might want to check that your GPS is on. E.g., “location” tile in your drop down menu.

I have the same xiaomi redmi note 7 phone with lineageos 18.1 (and previously lineageos 17.1) without gapps and without microg and the gps has always worked properly outdoors (the fact that it takes a while is normal but usually it’s a few seconds, I just tried it on the balcony at home and it took between 10 and 15 seconds). What firmware are you using from xiaomi: global or eea? You could try changing it.

Another thing you can do is try to see how many satellites your device is seeing and if it can lock the signal, you can do this with an app like My Location (Know your geo coordinates using on-device GPS and Network location providers) - https://f-droid.org/packages/com.mirfatif.mylocation or GPSTest (An app to test the GPS and GNSS functionality of a device) - https://f-droid.org/packages/com.android.gpstest.osmdroid

2 Likes

GPSTest https://f-droid.org/packages/com.android.gpstest.osmdroid

Is great to see what’s going on, visibility, types, etc

/LE: opps, didn’t see that was already recommended :slight_smile: