How to authenticate your Mastodon account

I’d like to use Mastodon on my phone. So I tried to authenticate.

Mastodon apps (Fedilab, Tusky) require me to authenticate in a seperate browser window. I tried all combinations of Fedilab and Tusky with the browsers PrivacyBrowser and FOSS-browser, but nothing happens when I hit the “authenticate”-button in the browser window.

This situation has been described on the PrivacyBrowser issues list as bug #268:
https://redmine.stoutner.com/issues/268

Did you manage to authenticate your Mastodon account and if so, please share your solution. Thank you!

It seems indeed that not all browsers work for this, I experienced that as well. It worked however with the “pre-installed” browser (the one that came with LineageOS). Not sure what’s the culprit with the others.

I am surprised that you can’t connect with Fedilab because, by default it uses its built-in browser and not custom tabs.
I stopped to use the grant_type password as it has a negative feedback (and also 2fa issues) but it should work by default.

Mastodon