Help! FDroid broke after adding Gmail account to Android phone

Hi, and thanks for your attention! I’ve been an F-Droid user for many years and prefer to use nothing else. Recently, I upgraded to a new Samsung S20 Ultra for faster hardware - FDroid was working fine on the 8yo phone I had, and it worked well on this new one as well for a few days, right up until I added a Gmail account on the phone in order to access my WhatsApp account.

Now, FDroid is frozen - all app logo display as greyed-out blank graphics, and I can’t install or update anything! I really just wanted some faster, newer hardware, but in order to get that, I need to pay for the privilege of the latest and greatest surveillance technology, and get locked out of my independent ecosystem? Argh!!!

Tips? Advice? Workarounds?
What am I missing? Where’d I go wrong?

Thanks in advance for your help!

1 Like

DId you see if the play protect in settings of playstore got turned ON after your adding google account? Also, check if the allow 3rd party apps installation is working.

Additionally, may I request you share few snapshots of the issue please, and if any logs if possible to get for you.

Play Protect

1 Like

Hi, and thanks! Friend of OP here (actually I wrote the post, but it’s to help my husband out - he’s way more advanced in tech knowledge than I am but I write faster :slightly_smiling_face:)

Anyway, thanks for the tips! We went in and deactivated Play Protect, but haven’t found where to allow 3rd party app installations. Is that under Play Store account settings?

Here are some photos - thank you so much for your help!

Uploading: 8496DF8B-4C2D-436A-B774-75D1949A3D67.jpeg…
Processing: 2AA1D6FB-6F5F-4C80-BB11-D28F6E003D66.jpeg…
Uploading: 2D0EFDA3-4074-4853-832B-113C1071495D.jpeg…
Uploading: A4D418B7-2630-4F4A-B92F-DB7F20064871.jpeg…
Uploading: 3393D5E3-C7D0-4439-9AA9-30B2F6CED120.jpeg…




We tried going back to download F-Droid again through the Firefox app, but encountered first a prohibition against downloading apps from here (which sent us to Settings, where we fixed that permission, thanks!) and then a second problem, the installer package of F-droid was said to be invalid. Current package linked to on the front page of F-Droid.org.



Found the Settings for F-Droid. Permission to install unknown apps is granted, and the phone has been turned off and on since then, but the problem persists.

The site blue button downloads version 1.14, you already have 1.15.4 for the Client. You can’t (and need not) downgrade.

Missing icons… do they appear if you slide mobile data all the way to the right in settings?

Pictures of errors when you try to install some app from F-Droid?

/PS: Funny that you cover the camera but still install apps from Play… or trust Google :slight_smile:

Was the added Google account one for work? The associated MDM policy may prohibit app installation.

Also unless you got a very steep discount (ie. <$200) for that device, I’d return on part of that extreme screen burn-in and get a device with proper aftermarket OS support like a new-in-box Pixel 6a.

Doesn’t it show a status bar icon when that happens?

Ich habe das selbe Problem. Ich habe F Droid auf diesem Samsung Note 10 verwendet, doch seit einem Geräteupdate kann sich die App nicht mehr updaten. Auch bei mir sind die Apps zwar beschriftet, das Bild ist aber leer. Wenn F Droid versucht zu updaten, bekomme ich eine lange Fehlermeldung, die aber zu kurz sichtbar ist um sie zu lesen, geschweige denn sie von englisch in deutsch zu übersetzen. Die Berechtigung, Dateien zu installieren hat die App. Aber auch das funktioniert nicht. Weder der Paketinstaller noch eine neutrale APK Entpakungsapp kann die App installieren. Ich vermute, dass Samsung oder Google selber aktiv verhindert, Apps aus einem anderen Store zu installieren. Da du schreibst, bei dir hat es sogar bei einem Gerät der S20 Serie erst geklappt und erst als du ein Google Konto eingerichtet hast, lief es nicht mehr, tippe ich auf Google! Ich habe ähnliche Probleme beim öffnen von nicht Mainstream konformen Seiten wie WirTube. Lösung habe ich keine gefunden. Aber genau das hält mich davon ab, mir ein neueres Handy zu kaufen. Es wird schon mit jedem Update schlimmer! Android 13 kürzte meine Akkulaufzeit von 22 auf 9 Std.!

Die installation von drittanbieter Apps kannst du bei jeder App in den Geräteeinstellungen - Apps einstellen. Die gewünschte App anklicken, dann kommst du in die Einstellungen der App wie Zugriffsrechte usw. Da ist auch eine Zeile " Installation von drittanbietern erlauben". Anklicken und erlauben. Wie man bei F Droid sieht, verhindert es Google aber bei manchen Apps trotzdem. So würde es jedenfalls funktionieren.