Force-reset misbehaving app?

osmand

#1

Is there any way to freshly reset any data of an installed app?

My case is with OSMand~:
It’s great, I love it - but recently it behaves weird, so I’d like to give it a fresh start.
Which I can’t find out “how” :expressionless: .

Here’s what I tried so far:

  1. Tried to reset its config: Didn’t find a way.

  2. Uninstall:
    Fails with the following error message:

Error uninstalling net.osmand.plus
Failed to uninstall due to an unknown error

  1. Downgrade:
    Downloads, but then fails to install, because the current version can’t be uninstalled: Same error message as above.

  2. Read install/uninstall logs:
    Haven’t found where (and if) they exist.

Grateful for any suggestions :smile:


#2

On Android 8 and later you will be announced that apps with Admin permissions can’t be simply uninstalled. You need to go to Android Settings Security Administrator and toggle it off for the app

How to clean? Android Settings Apps Osmand Storage Clean app DATA :wink:


#3

Thanks for your reply :smile:

I forgot to mention, it’s a Galaxy S4 running on Android 5.0.1.
And the “Clear Data” button is grayed out in “Settings > More > Application Manager > OSMand”.

So I’m still on square 1…


#4

…then uninstall the app


#5

Thanks! :slight_smile:

That worked!
I unmarked OSMand~ as “Device administrator” (for locking the screen) and now I was able to uninstall it.

I guess I’ll open a feature request to replace:

cannot uninstall due to unknown error

with:

“app has device administrator rights. Please disable them in order to uninstall”

:wink:


#6

As I said, it’s already implemented…in Android 8 and 9 you’ll get a notification from system.

Neither OSMAnd nor F-Droid can do much about it

Also https://gitlab.com/fdroid/fdroidclient/issues/1607


#7

Ah, okay!
Understood :smile:

Thanks again for making this work!