Fennec for f-droid connecting to cloudfront

Hi, I would like to now why fennec is connecting to cloudfront at startup, with bugreporting disabled and blank page, no tabs, no cache, just fresh install.

This is a fresh install. No synch, no telemetry.
It’s very annoying, sometimes it connects to multiple servers.

Don’t you think the title is misleading? It the Fennec browser complied by F-Droid that may or may not be trying to connect to cloudfront (I would like to see more details before giving a verdict) not THE F-DROID app itself. I would humbly request to change the title to reflect the fact.

1 Like

Can you say what domain exactly?

Do you have any extensions installed?

You’re completely right. I changed the title.

Tell me how I can help troubleshooting the problem. On my end this happens with a fresh install. Perhaps you could try to see if it happens on your end too.

If you need me to provide any kind of log, i’ll be happy ho comply.

What do you mean by what domain? If you mean the server it connects to, it’s in the screenshot.

As I said, this happens with a fresh install. I install from f-droid, I open the app and I get the connections to cloudfront.

So no extentions and no setup of any kind.

By googling I can tell this is an old problem. The solution reported in the last post of this thread doesn’t work in my case though.


It would be nice if the f-droid version would cone without these connections.

If it can be of any help, I’m on LTE. I haven’t tried on WIFI.

Please use Netguard, enable Advanced-Filtering and then start Fennec, look in app details in Netguard and see what domains are accessed

With netguard and filtering on I get the following domains:


With Net Monitor (org.secuso.privacyfriendlynetmonitor), though, I get the following:


I have no idea why I get so different results with these two different softwares.

Well, the first gets you the “domains” it connects to.

The second gets you the reverse IPs of the “hosting of those domains”

Now, going by those “domains”…I see nothing wrong. Do you?

Thank you, it’s all clearer now :slightly_smiling_face: It still looks like a bit too many connections, but I guess it’s the way it needs to be.

Use Netguard (if Pro) to block them, if that’s what you want… :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.