Fdroid always starts, only with system

Good afternoon:

I have the fdroid application, in its latest version.

It is also disabled automatic updates and all automatic options.

And I set whether or not to use the application. It always comes out with system startup.

Check in sd maid, for example. And disable the two options you have on startup at system startup. But it activates itself again.

I tried the last beta they released. And the last stable one. And they do the same thing.

It can not be done, so that it does not start with the system.

I upload screenshot of the two options that come out in sd maid of fdroid automatic startup. https://ibb.co/SmjVNHW

A hug and thanks for your help and time.

1 Like

F-Droid do uses the two permissions:

run at startup
Allows the app to have itself started as soon as the system has finished booting. This can make it take longer to start the phone and allow the app to slow down the overall phone by always running.

F-Driod tries to update repositories in the background and download them, so it receices boot complete. That requires permissions which you showed recently.

However, in your case, you just turned off the automatic download options but the permission is not turned off. Then you navigated to “sd Maid” again and turned off the permission, have you checked the system background services? That shows what is running in background and is accurate. I assume the “sd Maid” is just a permission controller.

By the way I did found a page of sd Maid on Github but guess what? It’s just changelogs and I can’t find any source code related files. That is just a page for “issues”, i.e. a blank page of nothing and still on Github, not open source!

Good afternoon:

First of all thank you very much for your help and response.

To say that the permissions of fdroid. To boot with the system. That comes out in sd maid in brown. I deactivate it and it turns back to has activated itself. More specifically the one I put in the screenshot.

In the settings of the applications. And in fdroid I have only given him storage permissions and foreground data. Nor in fdroid I have activated anything automatic update.

Also disable the options that comes out in fdroid in https://f-droid.org/es/packages/com.elsdoerfer.android.autostarts/ and those that more or less by name I can intuit that uses permissions fdroid, with https://f-droid.org/es/packages/io.github.muntashirakon.AppManager/ .Then disable loggers and tracker in https://forum.xda-developers.com/t/app-5-0-warden-app-manager.4122227/ of fdroid.

But still in sd maid the permission I uploaded the photo is activated alone.and it appears marked to boot with the system.

I don’t know whether to try https://f-droid.org/es/packages/open.com.permissionsmanager/ . Because I don’t know what else to try. I use lineageos 17.1 without gaps and with Adaway and Afwall+.

And in Afwall+ I’m giving permissions according to what I want to connect to the Internet or not.

A hug

Pd: From sd maid, I don’t know if it is here https://github.com/d4rken/sdmaid-public/blob/master/CHANGELOG.md . Although now that it says it all the code I do not see it either, as if you can see it in other applications on github or gitlab.

Good Morning @Licaon_Kter @Morgoth

Could you help me with this problem?

Receive a big hug and millions of thanks for your help and time.