F-droid STILL reporting incorrect latest version

This has been a constant issue since you people took over from the original maintainer. f-droid worked perfectly but this is always the case at every level, new totally incompetant upstarts always insist they know better. They have to change everything and then fuck the whole thing up. Now it is nothing but unreliable. I check for updates to my apps and it says Privacy Browser last updated 7 months ago version 3.2. So I check the developer site, he has version 3.3. So I download from his site and inform him f-droid is out of date. He says f-droid had latest version since january and it probably has but that does not take into account the current maintainers are total wankers that fucked this all up. Even the search is fucked up. Type Privacy and expect any app named privacy to be far down the list.

1 Like

The app and the website both show 3.3 as the latest version of Privacy Browser.

Maybe something else is the problem. Have you tried rebooting/updating your phone, updating F-Droid, etc.?

As far as I know, search results in the app are shown in alphabetical order. Perhaps, there should be an option in there to also sort the results according to relevance. That would be a nice feature request.

1 Like

My Stoic Reading app isn’t updating either, something is wrong on f-droids side. The build metadata is up to date but the APK isn’t being generated

In the case of Stoic Reading app the build fails, see here. The reason is that the F-Droid build server does not know about Build Tools revision 29.0.3. I had the same problem with my app and I downgraded my gradle file to use revision 29.0.2. I opened an issue on gitlab.
Update: Should be fixed in the next build.

3 Likes

Thanks for the tip, I suspected it was something like that, I went updating a bunch of stuff in the app after Android Studio told me about AndroidX including updating the Build Tools.

Is there any progress on this, my app still hasn’t updated. I’m going to downgrade Build Tools too

The issue was fixed, but it needs to be deployed. We have to wait until Ciaran does this.

2 Likes

Here you can see from the screen shot, the f-droid app reported privacy browser was last updated 7 months ago https://i.imgur.com/UYfkeWJ.jpg the f-droid app is clearly not synching with the app servers. I found a way force it to sync by going into android settings and manually deleting the f-droid cache. This forces the app to sync the next time it is run. By doing this I found there is a whole bunch of updates to my apps dating from last year!!

As for the search, I dont know why you would say the search results are in alphabetical order, do you not use the app? They are not even remotely in any kind of order. Type the word privacy and the privacy browser app is way down the list.

I have yet to encounter this problem. What Android version are you running?

It’s either ordered alphabetically or according to most recently updated. You can toggle between them by clicking on the icon in the upper right corner (in the latest stable F-Droid release).

You’re right, though. It would be great to have at least an option to sort according to “relevance” as well, which is I think how apps are most commonly sorted in app stores.

Who decides relevance? That’s subjective…

Whoever decides to write the code decides what “relevance” is.

It could be as simple as “if [app name contains search keyword], then [app is give more ‘relevance’ and will appear higher in the search results]”, to something approaching the complexity of Google PageRank or whatever search algorithm YouTube uses.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.