F-Droid says "Repository was not signed correctly..." on custom repo

repo
fdroidserver

#1

I followed the instructions for setting up an F-Droid app repository, installing fdroidserver via apt on Ubuntu 16.04. Running all the commands with -v shows no errors or warnings, but when I add the repository to F-Droid it complains “Repository was not signed correctly: Signing certificate does not match!”. If I include the fingerprint when adding, I get “Repository was not signed correctly: Supplied certificate fingerprint does not match!”.

I’m at a bit of a loss here. The repository is at https://repo.netsyms.com/fdroid/repo if anyone wants to look at what I did (Apache directory listing is enabled).


#2

Well, I still don’t know what was broken, but after adding the Ubuntu PPA doing an apt upgrade, running fdroid update, and removing/readding the repository on the F-Droid app, it all works now.


#3

Could you go back in your bash history and post the statements you have executed after your apt-get upgrade?
I’m having the same problem (signing certificate does not match) but still can’t get it to work


#4
apt upgrade
fdroid update -v
fdroid server update

Did you remove the repo from the F-Droid app, clear the cache, and re-add it? It didn’t work until I did that.

FYI, fdroid --version gives me 0.8, so if you don’t have that get it.


#5

Well that seems to be my problem. I had 0.6.0. The version that is shipped through Ubuntu’s official channels is outdated. Adding the apt repository and running apt-get dist-upgrade and then updating my server solved the problem for me.


#6