F-Droid says chromebook needs switched to Dev, but it already is

Years ago, I put F-Droid on my Android phone. I wish I could remember how I did it.

Now, I want to put F-Droid on my chromebook, CB5-312T, Chrome Version 108.0.5359.6 (Official Build) dev (32-bit), “Currently on dev channel,” Android version 9.

After I install F-Droid, I want to install Boinc from F-Droid. I downloaded the .apk files for F-Droid and Boinc.

I never ever installed anything using an .apk file; neophyte.

When I click on the F-Droid.apk or Boinc.apk, I get a pop-up warning that the chromebook needs to be switched to Dev mode.

It’s already on Dev mode.

I tried restarting the chromebook after switching to Dev mode. I let the chromebook marinate for a few months. It’s been through a couple of Chrome updates. Then I tried clicking the .apk files again, but it still tells me I need to be in Dev mode, in which it already is.

Is there anything else I can do to get this chromebook working on F-Droid?

Thanks, -neil-

I think there are more convenient forums for this. I don’t think there are many people here who use chromebooks :man_shrugging:
Good luck

Hope springs eternal.