F-Droid is default app for Google Play Store


When I want to upgrade an app installed by the Google Play Store and not available on F-Droid, my phone (Android 11) opens F-Droid instead of Google Play.

The standard upgrade of Play Store apps (and F-Droid apps) works normally.

I have a banking app that has to be replaced by a new app, so I have to follow a procedure provided by the old app, which tries to install the new app and F-Droid is started to do that instead of Google Play and that does not work.

How to set Google Play as the default?

Hello @kees ,
try going to Settings > Apps > F-Droid > Set as default > Clear defaults. This should solve your problem.

1 Like

@DwainZwerg , thank you for your reply.
At first I didn’t got the choice for F-Droid and searching for it did not work either.
I had looked here before
When searching in other settings, I finally got the choice for F-Droid in Setting > Apps (don’t know how I did that) and was able to clear then

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.