F-droid app fails with Android 11 Samsung Tab A7 SM-T500

I used F-droid on my tablet for a while. Recently got a message that an update is available. I downloaden it, but could not install: “An erforderlich occurred while parsing the package”
Downloaded the apk from f-droid website.
Warning: This app was designed for an older android version!
Installed anyway.
When open the app, error message: This app is erroneous. Empty cache and try again.
Emptied cache, but same result.
Installed then the same apk to an older smartphone (SONY Xperia X, android 8.1), it works.

Last try: Installed the beta version from f-droid website. This app can be started, but no package source are displayed.

PS: I installed almost the F-droid app v3.2.9 (2021-02-14), that originally worked on my tablet - same error as before.

What is your architecture? Some phones are arm/arm64 etc. Probably you are using an incompatible apk?
Edit: Yours is ARM CPU. Though FDroid apks do not have that issue. Try this build: https://f-droid.org/repo/org.fdroid.fdroid_1016000.apk

*101600.apk shows the same behavior.
First comes up a message from Play Protect, that the app blocked because it is designed for an older android version and does not fulfill the actual security requirement, but this can be ignored.
When starting the app, it is closed instantly, a a device care message pops up, that F-droid failed due to an app error.

Try turning on option to install from unknown sources and then try turning off play protect (only for the sake of installation and launch). Other than this try sharing the logs (masked data) on fdroid git and hopefully someone can help. Sorry, I know very very little.

Turning off Play Protect allowed to install and run the current 1.15.3 version, now it works.
Thank you, I will remember that for future issues!

1 Like

Glad to hear it solved your problem. Glad I was able to help. :slight_smile: