F-Droid and old blackberries?

hello

Im the owner of few old blackberry devices
the older one is a curve, running qnx 7
the newers one runns blackberry 10. It have a v4 android compatibility. I succced to install old fdroid on it, but impossible to refresh repositories (ssl certs error?)
I’d like to know how to install fdroid and make it working on those? in a way to install xmpp and sip clients, as possible?

thank you!

Those support Android 4? Maybe older versions like Conversations from Archive repo.

This old version? Running on old Androids · Wiki · F-Droid / wiki · GitLab

Do try https://f-droid.org/en/packages/eu.bubu1.fdroidclassic/

Or maybe https://f-droid.org/en/packages/org.gdroid.gdroid/