Error in fdroid update -c ubuntu 16.04 - SOLVED

Hi, we move our main fdroidserver from Bebian 9 to Ubuntu 16.04 server.

We install fdroidserver from repositories, but when execute a “fdroid update -c” in the repo directory got this error:

Traceback (most recent call last):
  File "/usr/bin/fdroid", line 146, in <module>
  File "/usr/bin/fdroid", line 120, in main
mod = __import__('fdroidserver.' + command, None, None, [command])
  File "/usr/lib/python2.7/dist-packages/fdroidserver/", line 37, in <module>
from pyasn1_modules import rfc2315
  File "/usr/lib/python2.7/dist-packages/pyasn1_modules/", line 67, in <module>
class DigestedData(univ.Sequence):
  File "/usr/lib/python2.7/dist-packages/pyasn1_modules/", line 72, in DigestedData
namedtype.NamedType('digest', Digest)
  File "/usr/local/lib/python2.7/dist-packages/pyasn1/type/", line 115, in __init__
self.__ambiguousTypes = 'terminal' not in kwargs and self.__computeAmbiguousTypes() or {}
  File "/usr/local/lib/python2.7/dist-packages/pyasn1/type/", line 232, in __computeAmbiguousTypes
ambigiousTypes[idx] = NamedTypes(*partialAmbigiousTypes, **dict(terminal=True))
  File "/usr/local/lib/python2.7/dist-packages/pyasn1/type/", line 114, in __init__
self.__tagToPosMap = self.__computeTagToPosMap()
  File "/usr/local/lib/python2.7/dist-packages/pyasn1/type/", line 205, in __computeTagToPosMap
for _tagSet in tagMap.presentTypes:
AttributeError: 'property' object has no attribute 'presentTypes'

some idea?


We update the repo to use the GuardianProjects repos, and now the error is this:

Traceback (most recent call last):
  File "/usr/bin/fdroid", line 150, in <module>
  File "/usr/bin/fdroid", line 123, in main
    mod = __import__('fdroidserver.' + command, None, None, [command])
  File "/usr/lib/python3/dist-packages/fdroidserver/", line 41, in <module>
    from . import index
  File "/usr/lib/python3/dist-packages/fdroidserver/", line 37, in <module>
    from fdroidserver import metadata, signindex, common, net
  File "/usr/lib/python3/dist-packages/fdroidserver/", line 21, in <module>
    import requests
ImportError: No module named 'requests'

Edit #2
SOLVED the problem what teh version of the android-sdk, When instal the new build-tools all starts working Again!!

Thanks you for your time!!