Element-android: found unknown maven repo

I ran a fdroid-server on Ubuntu, downloaded fdroid-data, Run on the server fdroid - build - v im.vector.app: 40106034, perform ERROR 2023-08-08 06:08:17, 610 ERROR: Found unknown maven repo ‘Index of /repositories/snapshots’ at build. Gradle. How am I supposed to track him down for this mistake.

1 Like

Here is my build. Gradle connect: https://github.com/lxftheking/element-android/blob/xuefei_li_main_1.6.3/build.gradle.
Before that, I built im.vector.app:40105320. The apk was successfully packaged without any problems. Upgrade to version 1.6.3, build the gradle file add ‘Index of /repositories/snapshots’ this mirror address, then execute a build command failed.
Here is some of the added code

Below is a picture of the execution error:

I have tried to check the information in scanner.py in fdroid-server and found that there is indeed the address of the warehouse in it, but I don’t know if I read it correctly.

Thank you for getting back to me

Please use fdroidserver from repo directly, this is not an issue in latest code :wink:

Thank you for your reply.
I now use previously installed solution or fdroid-server, but I adjusted the project build.gradle ‘Index of /repositories/snapshots’ in the address, Changed to “https://oss.sonatype.org/content/repositories/snapshots/”.
PS: I only successfully verified this solution on im.vector.app.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.