DivestOS: long term device support with enhanced privacy and security

that means the update didn’t work and it reverted back to the other slot.

There weren’t many low level changes from last month that’d cause such an issue. Perhaps try again once more?

I pushed a 20.0 build, but Wi-Fi was broken and no one gave me logs so I dropped it for now.
17.1 is working albeit old.

I tried 3 times, no chance. Then I started the boot menu, did a reset and then started the update. Still no chance.

a wipe is never the solution.

I’ll note the breakage on the website and look further.


Maybe, but if nothing else works, it can’t hurt either.
In the hope that you find a solution, thank you.

I’m having this weird bug in the battery stats and I know most of this anomaly was having my USB dongle (with earphones attached) plugged in and without playing any sound/video. It seems to have had more battery usage without the dongle but only a few more mins. Also had restrict usb until unlocked.

20-20230907-dos-redfin - This is what I’m using currently.

Yea, longterm AOSP bug, some system services don’t get grouped properly and show up as a nameless icon.

As an aside your battery looks better than fine.

Ahh, I thought it may be something like that but wasn’t 100% sure.

Anyways thanks & keep up the great work!

1 Like

Too bad, today the same as the last update.
There is always a boot loop, first the message “Please lock yout Bootlader” then the Sony logo on a white background. At some point after several runs DivestOS starts with the version from 10 August 2023.
I have installed the update several times. Is there anything else you can do?

I flashed the latest LineageOS version on an identical XA2, there were no problems.
It may only be due to the low-level changes from last month that would cause such a problem.


Thank you, but if I should change something with it now I must confess that I am not able to.
Then I just stay with the version of 19.07.2023.

Regarding nlp, combining the info on:

and trying to get nlp to work on a fp2 running a fresh divestos v18, i guess it is not possible anymore (without using some google service) to do so? it seems there are viable backends like local nlp backend, but no viable nlp providers anymore?
(ie local only open source nlp providers without asking eg google that are still fairly secure)

tested using with local nlp backend, nomatimnlpbackend, and unifiednlp (gapps) from f-droid.
the self check of unifiednlp gives two failing checks:

  • not registered in the system
  • network-based location not enabled

or am i mistaking?


note: thanks for DivestOS !, it is much appreciated to have this option to continue to use this phone in a secure way

DivestOS now includes some support for microG 0.28 or later


  • 0.28 and later removed support for plugins
  • 0.29 already includes some of that functionality
  • more important Divest DOES NOT INTEGRATE microG, so the location code IS NOT working

No, in Divest you can’t use any nlp providers.

1 Like

tnx for the feedback,

also i noticed f-droid isn’t privileged to install all updates at once, you need to confirm each one of them,
can i change this in DivestOS?

F-Droid Client 1.19 alpha and KDE Connect | F-Droid - Free and Open Source Android App Repository only on Android 12 or later (aka DOS19 or later) it can

I saw on Reddit that you said you’d removed the firmware from the OP7 file and was wondering if thats the case still

Please see the ‘Firmware Included’ status on the device downloads page.
Firmware is included for all OnePlus 7 variants.

1 Like

Hi there. I have a nexus 5. When I download the ota and click install, the device reboots into recovery but I am unable to unencrypt using my screen pin. Is there a different pin that I need to use? Thanks in advance

Okay, I’ve installed the divestos recovery and installed via adb. Thanks all the same

1 Like


sounds like you had TWRP recovery installed, old versions of it can’t handle the newer Android encryption

glad you figured it out

1 Like