DivestOS: long term device support with enhanced privacy and security

@x3e09, @ushilives, @gentr
@SkewedZeppelin
Thanks for your tips.

@gentr
The follow up video was interesting, showing how easy battery replacement can be on the Poco F1 - just screws, no glue.

@All
The video recommended by @gentr gives the impression that the repair is very easy. So, for safety’s sake, I installed the tool on a “neutral” second PC system. As a portable version, the tool does not make any registry entries in Windows, but the login requires access data that I do not have. I would gladly pay a reasonable fee for the repair, but the whole thing has to be transparent.

My current summary is: The loss of the “beryllium” hurts me, but it does not plunge me into a crisis. I was aware of the risk of a possible loss when flashing a custom ROM. Now I’ve just had bad luck. That won’t stop me from continuing.

2 Likes

Hi,

I have quite strange issue on my m8 and same on friends FP3. Accessing site seznam.cz doesn’t work in any browser regardless. Tried also disabling private DNS with no success. What could cause it? This is output from termux. Other phones/computers on my network resolve it correctly.

ping_seznam

I see it’s on https://divested.dev/hosts-domains but that’s totally legit site including many sub domains in the list, maybe apart ad*.seznam.cz can it be disabled/overridden somehow?

@mahdi1234

seznam and some others have been unblocked.
The list only intends to block ads/trackers/malware, please let me know of any other falsely blocked sites.
There is more information about this on the page:

Thanks, does it mean wait for the next build for given devices or lists can be somehow refreshed (not clear from the page how)?

PS - might be worth adding into troubleshooting when site doesn’t resolve checking those lists

OnePlus 6T ‘A6013’ (fajita) + DivestOS 18.1 /11.0 / R

The initial problems (here and here) when flashing DivestOS to my OnePlus 6 ‘enchilada’ with OOS 11 are unforgettable. Only when @SkewedZeppelin implemented the Android 11 LineageOS patches was I able to boot without serious errors. The happy ending (here) with Verified Boot Re-Locked Booter was only a few days ago.

Now I have a OnePlus 6T ‘A6013’ (fajita) with OOS 11.1.2.2. Still a bit anxious because of the disaster with my Poco F1 is my question: The installation instructions of the LineageOS Wiki give the …

Pre-installation instructions
In some cases, slot b may be unpopulated or contain much older firmware than slot a, which can lead to various issues including a possible hardbrick. We can make sure this does not happen by copying the contents of slot a to slot b. This step is NOT optional.

Why wasn't this note made by @SkewedZeppelin here?

Why wasn’t this Pre-installation instructions made by @SkewedZeppelin here?

@mahdi1234
would need to wait for next update

@fossys
I will add a note to sync the slots.
However enchilada/fajita include the firmware in the OTA images:

I guess that is the perfect time to ask something I wanted to ask for quite some time.

Have you ever thought about packaging DivestOS with AdAway to manage the hosts file?

I guess the answer is “yes” and I can think of very good reasons not to do it (less external dependencies, security issues, can root apps even be shoehorned into a non-rooted ROM?) but I still have to ask :wink:
With AdAway users could add their own inclusion/exclusion rules and would (in the current case) not have to wait for updates.

My last Android before DivestOS was a rooted (Magisk) LineageOS. Rooted so I could use AdAway and AFWall+ which gave me a tremendous feeling of control over my system and which I both miss dearly. If DivestOS came with those two available it would be Android heaven for me.

Just a modest suggestion.
Thank you very much for DivestOS. A much MUCH better user experience than LineageOS without Gapps.

Samsung Galaxy S5 Plus ‘kccat6’

Build: divested-16.0-20211217-dos-kccat6.zip

The Samsung Galaxy S5 Plus ‘kccat6’ has been a loyal companion for me for years. It is rugged, IP67 certified despite the removable battery and equipped with a proprietary 21-pin USB 3.0 (OTG).

Until just now, it ran the latest December 2021 build of LineageOS-for-microG 16.0 and TWRP Recovery.

Divest OS 16.0 / 9.0 / Pie build divested-16.0-20211217-dos-kccat6 was installed twice: once via TWRP “Install” and once via “adb sideload”. Both times DOS booted only up to the Samsung S5 logo, paused for about 10 seconds and rebooted automatically, over and over again: Bootloop without end, thus non-functional.

The subsequent flashing of the current /e/ OS-P build e-0.20-p from 2021.12.16 with TWRP worked right away. Likewise the correct boot process. The ROM is functional.

I still remember (20.07.2020) a DivestOS that did not boot correctly with the Samsung Galaxy S5 ‘klte’.

you need to flash first divest os recovery from twrp and try again from divest os recovery like on lineage os.

@agschaid
the big issue is that I have to make it work for 5 (and soon 6) versions of Android.

@fossys
I received a report a few days ago about kccat6 not booting and I already commited a potential fix for next builds:

@SkewedZeppelin,
it wouldn’t be wrong if you would report on your web page 'Device Downloads’ the note ‘Status: Broken’. This will save potential users from a negative user experience.

I’ll try your new release again.

That is a VERY good reason that I haven’t even thought of :wink:

Sad for me. But very understandable.

Unfortunately, it would also take away our (unrooted) ability to use Tor with the VPN feature iiuc.

I only have dangerous half-knowledge in these things but I don’t think that would change anything.

DivestOS already sports a custom hosts file and uses it to redirect calls to some (known, malicious) domains to nirvana. AdAway basically does nothing except enabling the user to manage and manipulate that hosts file. At least the rooted version. I think there is also an un-rooted version of AdAway that uses some VPN-magic. Maybe that is what you are talking about?

I just have installed DivestOS in a Samsung Galaxy S4 mini and works smooth in Android 11. Thanks for this.

8 new devices added today, they may or may not boot:
lavender for @darhma
h910 for @Ryu945
xz2c for @PorFin

have fun!

5 Likes

Google Pixel 3 XL ‘crosshatch’

Build: divested-18.1-20211212-dos-crosshatch

Status: Likely Works
Relockable: Yes, Untested

GrapheneOS 12 Pixel 3 XL (legacy) and CalyxOS 11 builds works with ‘Relocked Bootloader’

Arrows-12.0 ‘official’ vanilla, /e/OS-R, LineageOS 18.1, LineageOS-18.1-for-microG builds works, however without ‘Relocked Bootloader’

@SkewedZeppelin
On which assumption is the status “Likely Works”?
What is the risk that the ROM will not boot?

@fossys
there have been update checks to the server from a crosshatch build
that means they likely work

@SkewedZeppelin
Yes well, only does the ROM also work with re-locked bootloader?
Why don’t users give feedback? That’s the least that should be expected as a thank you for your continuous work.