Debian Stretch fdroidserver wants Android SDK

I run a fresh Debian Stretch server. According to the docs on, all I need to do is a simple:

apt-get install fdroidserver

That works. According to install docs I just need to run

fdroid init

in the appropiate directory. The doc also mentions:

<If you only want to make F-Droid repositories of APK files that you already have or don’t know what this means, then you can skip this section./>

But running

fdroid init

results in:

ERROR: No Android SDK found!
ERROR: You can use ANDROID_HOME to set the path to your SDK, i.e.:
ERROR:  export ANDROID_HOME=/opt/android-sdk
Enter the path to the Android SDK (/opt/android-sdk) here:

I just need a simple repository. In the I can’t find an option to switch off the SDK. What am I doing wrong?


Apparantly the dependency structure is missing some packages. Running

apt-get install aapt

fixes the problem. There is still an error that there is no Android SDK, but now “fdroid init” continues the initialisation.


1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

To keep the dependencies manageable, some of them are set as Recommends:. Sounds like your box is setup to not automatically install Recommends: You could also do:

apt install --install-recommends fdroidserver