Checkupdates fails on first upload

I am trying to upload my app following the Submitting to F-Droid Quick Start Guide but keep getting the error

vagrant@e041a71b5152:/build$ fdroid checkupdates --allow-dirty com.voklen.daily_diary
2022-11-29 17:39:14,379 WARNING: ipfs_cid not found, skipping CIDv1 generation
2022-11-29 17:39:20,183 INFO: Processing com.voklen.daily_diary
2022-11-29 17:39:24,751 ERROR: ...checkupdate failed for com.voklen.daily_diary : Couldn't find any version information

My com.voklen.daily_diary.yml is

Categories:
  - Sports & Health
  - Writing
License: GPL-3.0-only
SourceCode: https://github.com/Voklen/Daily-Diary
IssueTracker: https://github.com/Voklen/Daily-Diary/issues

Summary: A diary that starts with a blank page every day
Description: |-
    Jot down whatever you want throughout the day and the app will reset
    the next morning. All previous days are stored in plaintext files which
    can be exported and moved to a different device.

    Settings are stored in a config.toml file that can also be moved between
    devices.

RepoType: git
Repo: https://github.com/Voklen/Daily-Diary.git

Builds:
  - versionName: 1.0.0
    versionCode: 1
    commit: v1.0.0
    subdir: android/app
    gradle:
      - yes

AutoUpdateMode: Version v%v
UpdateCheckMode: Tags
CurrentVersion: 1.0.0
CurrentVersionCode: 1

I’ve tried finding threads already on the forums, tried many options with quotes and without it, Version and Version v%v, different subdir-s as well but it always seems to give this error.
Any help is appreciated, thank you.

Your app seems to be flutter based, so take a look at the flutter template: templates/build-flutter · master · F-Droid / Data · GitLab

2 Likes

Thank you for such a quick response, I’ll try that right now

1 Like

Also, while you’re at it, pls setup flutter as a submodule so you can update it as you need and F-Droid can autoupdate :wink:

Sorry but I can’t seem to find any information on how to do that, what exactly do you mean by this? :face_with_raised_eyebrow:

Oops, forgot the link: Encourage devs to switch from srclibs to submodules as much as possible (#2803) · Issues · F-Droid / Data · GitLab

2 Likes