Certificate problem

Hello. I tried to check for updates on one of my Android 7 devices and saw a pop-up notification with this message:

F-Droid: Unacceptable certificate...

Anyone else seeing this?

I remember that Let’s Encrypt cross-signed intermediate certificates are set to expire in 2024… But this affects not only websites, but also applications?

Do this at the moment: Let’s Encrypt ISRG Root X1 and Privacy Browser – Stoutner

keep an eye on Let's Encrypt is losing its cross-signature, no longer working on Android older than v7.1.1. (#2102) · Issues · F-Droid / Client · GitLab

Thanks for the link. I’m afraid this doesn’t work for 7.1.2.

explain what you did and what happend

Also, this is for the default F-Droid repo or you added some other repo?

I didn’t do anything, that’s the point. In the morning I unlocked my smartphone and connected to wifi. A cross appeared next to the wifi icon… I opened the list of networks, and it said that I was connected to my network, but: “Connected, without Internet.” I opened the browser and the Internet works, but not all sites open.

Then I tried to update the f-droid repositories and received this notification. Yes are the default repositories.

try mobile data then

other wi-fi

maybe it’s a networking error instead

I can’t try mobile data… But other devices work fine with this wifi. In a nearby cafe with a different provider, everything is the same.

F-Droid on those other devices, that run Android 8 or later, is fine?

Everything is fine on Android 11

so you tried this? added the cert to your system? maybe restarted the device too?

F-Droid works fine on my Android 6 device (where I added that cert years ago), hence your issue is odd.

Yes, I added the certificate and rebooted. I didn’t see any results.

why some sites don’t open?

I don’t know… I can open the f-droid.org website without any problems and it will work fine. But I can’t open duckduckgo.com. I am greeted with the following message: “This site requires the use of a secure connection.” I have no idea what’s wrong.

then maybe your connection is … broken… somehow…

try a different Wi-Fi where duckduck works at least, then try in F-Droid Client again

I don’t know what it was. I had to reflash the device to fix this.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.