Can't install on older Asus tablet

I have an old Asus Zenpad (released August 2015, Android version 5.0) and was hoping to install some F-Droid apps.

When I download F-Droid in Firefox browser and then click to open, I get a pop-up saying “no app found to open apk files.” If I go to the downloaded file in a file manager and click on it, I get a message saying “there was a problem parsing the package.” If I download the file in Chrome browser and click to open, it gives the problem parsing the package error. Clicking an old Asus app installation apk in file manager doesn’t give me this error.

I’ve set the security options to allow installation of apps from unknown sources, so that shouldn’t be the problem. I also tried rebooting the device, as advised in an old thread about installation problems.

Is there something else I can do to install the app on this device, or is it just too old?

The official F-Droid app requires Android 5.1.

You can try F-Droid Classic instead: F-Droid Classic | F-Droid - Free and Open Source Android App Repository

Thank you. I tried that and got the same result. But I no longer really need it, as the main thing I wanted for the old tablet was APK Extractor and I was able to get that from Google Play. Not sure if it’s the same one available here, but it worked and let me copy the two apps on the old device that I can’t get anymore.

1 Like