Can't download any APK from F-Droid website

tried downloading apk s from this page but got nothing
Smart AutoClicker | F-Droid - Free and Open Source Android App Repository

tried fdroid download link from main page nothing
if i open in new tab url loads but no download started
tried different browsers nothing no files

We recommend you use F-Droid Client to install and update apps. the web site is for convenience only.

That being said, works fine for me, so maybe retry.

still cant download anything, was able to do it before, what to do :confused:

Are you using Tor or a VPN?

Are you in a country that’s known for its “great firewalls” around the Internet? :person_shrugging:

(if on Linux or macOS) what’s the output of curl -I ?

no vpn no tor no great firewall, west coast usa, no curl on tablet

Which browser did you test, eg, Firefox ? You looked in Downloads folder in file manager to see if maybe files were downloaded anyway?

nothing in downloads list or downloads folder, tried firefox, opera, duckduckgo browser

Are using Wi-Fi or LTE (mobile data)?

im using wifi

well just double checking ddg browser, i downloaded this no problem right now
so for some reason fdroid doesnt like me
maybe something to do with gitlab?

F-Droid apps are not hosted on Gitlab :slight_smile:

Are you trying the correct url?

What happens when you try downloading from one of the official mirrors?

Is downloading from our github releases page also not working?

1 Like

im clicking links on the page i linked in o
root post
when i click your url links nothing
but when i click mirror link im getting downloads
so thanks for that

as an aside, ive run into this often w sourceforge over the years, opera… redirections can get buggy

another aside regarding gitlab, its when you click on issues innfdroid main site that it takes u there and a big warning on top about gitlab update mayor breakage yesterday

Yes, the metadata is hosted there and code, related but not to your issue :slight_smile:

Now that you have installed the Client, it will try to connect to the mirrors if it sees a download fail, so it takes care of this for you :wink:

I smell that you have an older device maybe with Android 6 or 7, is this true? If so, maybe you need to do these steps too: Let’s Encrypt ISRG Root X1 and Privacy Browser – Stoutner else more apps might refuse to connect to sites.

device from 2023 (fire os updated april) browser ddg from october 2023

The big change that comes with Fire OS 8 is that it move to Android 11 ok, so that’s recent enough to not be affected by that Let’s Encrypt issue the :person_shrugging:

Anyway, use F-Droid Client and do report any other issues that you see :wink: