Cannot install Termux:Styling

Hi, I installed Termux from F-Droid, but when I tried to install Termux:Styling package from official F-Droid client, it said that instalation failed due to an unknown error. When I tried it with the Neo Store client, it said this:

What should I do?

You already have it installed with a different signature/from a different source?

I thought that might be the case, so I uninstalled Termux and every Termux addon package on my phone, restarted it, and then installed Termux from F-Droid. Then Termux:styling and it showed this error.

I figured it out!

I accidentally enabled the Kali NetHunter repo in Neo Store. They have all the termux addons and termux in the repo, except for Termux:Styling.
For some reason, Neo Store preferred the apps from the NetHunter repo, even if they was the same version as the ones from F-Droid.
I installed the F-Droid repo versions and it works. Sorry for me being dumb.


Think the order in the list might matter

I don’t think so, F-Droid was on the top.
I think it counts the one uploaded later as the more up to date, even if they have same version.

The later repo"s contents take precedence, at least as far as listing is concerned. Been hit by that a number of times.
Multiple repos with an app that has a same package name means having to pay a little more attention in some cases.
Signal, for instance, will have one entry with downloads from three different repos (in my case).

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.