Build server detects wront gradle version

I’m referring to this recent fail:

It says

Found 3.3 via distributionUrl Downloading missing gradle version 3.3

But the distributionUrl is set to 7.3.3

I think that is cause the follow-up error “could not determine Java Version”.

The build was working for previous versions and there is also a gitlab pipeline in the project that verifies the build .

Any advice how I can fix this?

Already fixed: appleflinger - bump gradle (fe04e4c8) · Commits · F-Droid / Data · GitLab

Hi, thanks bro!

Apparently there was another gradle-wrapper-properties-file in the android subdir. It was sitting there unused since the creation on the project and was always ignored. Now the build-server has started to pick this file up and use Gradle 3.3 :grinning:

I’m not sure why that file is there and what it does. I will probably try to delete it next time and hope it doesn’t break again.

thx again for the quickfix

Hi @Licaon_Kter ,

there is still the same error in the build, so I guess the rebuildin the yaml file doesnt do it.

nevertheless Your quickfix is re-tagged in the upstream.

So if you could remove the rebuild and the latest version from the yaml file, it should be picket up again and work correctly, right?

The “currently” running cycle has not (yet) tried to build the updated recipe: running - F-Droid Monitor

Have patience :wink:

Oh I see.

Thanks. Now it was successful.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.