Aurora store problem

What’s going on with Auroa store? The last 3 releases fail search: when you start typing, the app shuts down.

Logcat shows weird entries such as:

11-12 11:14:24.095 12566 12590 E AndroidRuntime: FATAL EXCEPTION: DefaultDispatcher-worker-2
11-12 11:14:24.095 12566 12590 E AndroidRuntime: Process: com.aurora.store, PID: 12566
11-12 11:14:24.095 12566 12590 E AndroidRuntime: java.lang.Exception: Kuchh toh gadbad hai Daya!

|11-12 11:14:24.095 12566 12590 E AndroidRuntime: |at com.aurora.gplayapi.helpers.WebClient.fetch(SourceFile:90)|
|---|---|
|11-12 11:14:24.095 12566 12590 E AndroidRuntime: |at com.aurora.gplayapi.helpers.WebSearchHelper.searchSuggestions(Unknown Source:22)|
|11-12 11:14:24.095 12566 12590 E AndroidRuntime: |at i5.c.h(SourceFile:3)|
|11-12 11:14:24.095 12566 12590 E AndroidRuntime: |at i5.b.M(SourceFile:14)|
|11-12 11:14:24.095 12566 12590 E AndroidRuntime: |at r6.a.l(SourceFile:9)|
|11-12 11:14:24.095 12566 12590 E AndroidRuntime: |at i7.i0.run(SourceFile:1)|
|11-12 11:14:24.095 12566 12590 E AndroidRuntime: |at n7.l$a.run(SourceFile:4)|
|11-12 11:14:24.095 12566 12590 E AndroidRuntime: |at o7.j.run(SourceFile:1)|

Try to open the Play page in your browser then press “open in app”

Might be one of the known issues iirc

Works on most OS’s. Probably some privacy setting or indexing settings in your OS is triggering it. However, raise it as a bug with logs.

Also, maybe you have not set opening links with app in settings.

Version 4.2.5 works fine with the same rom.

On 4.3 versions, I could see the apps and can install them without problems. It’s only when I click Search and start typing, the app shuts down.

I am running Aurora Store 4.3.5.53 on a Samsung phone running Android 13.

I have no problem searching for an app in Aurora Store and installing it.

As others suggest, I suspect there is a problem particular to your phone.

BTW I can’t find “open links with app” on my phone now. I know I have found it in the past. Maybe it is not available in Android 13.

Optimum has his own OS. Probably some Lib issue there. For your open links with, if you have playstore too, first remove their links and turn it off. Then set the Aurora links.
System Settings > Apps (all apps list) > Aurora Store > Settings (not inside app) > Open By Default (similar words as per OS) > Check ps ones and then click add links option below > market.android as well as amazon one. Done.
First remove the other playstore one by similar steps.

1 Like