Application to clean the system

Good afternoon:

I wanted to ask if you know of any application that cleans cache, deleted things, temporary, etc … for lineageos?.

I do not know if app manager has this function.

A hug and thanks for your time

Hi gallegonovato,

How about “Android cache cleaner”?

You find it on F-Droid… :+1:

Take care,

Michael

2 Likes

Android doesn’t need a “cleaner”. Apps like that on PlayStore are a scam.
LTE Cleaner
I guess, but it’s pointless.

2 Likes

@Morgoth you may be right, I don’t have the knowledge about that, but @gallegonovato asked for it, so I made a suggestion. And as I wrote, that app is not from the PlayStore, it’s from F-Droid…

Bye,

Michael :wink:

2 Likes

I know, that’s why my message was not intended to respond to yours. Have a good day

2 Likes

Good afternoon @michael_s and @Morgoth

First of all thank you very much for your help and time. And for your answers.

And please don’t get angry because of me.

The truth is that sometimes the cache of applications, sibo clean them. It makes them close or become slow, or do not work well.

For example it happens to me with Adaway. Since after updating and so on. If you look at the cache is altisima. And I always went to settings, applications. And there hiba clearing the caches.

I’ll try the one you tell me to see how it goes.

Thank you both very much for your answers and help :ok_hand:

That applies to the so-called “RAM boosters”, but not necessarily to cache. An app can have some “broken files” in its own cache and misbehave because of that (e.g. crashing when it cannot load something correctly).

But true: you don’t necessarily need an app to solve that. Just go via Android’s Settings › Apps and scroll to the app in question, open its entry, and select “clean cache” from there (sometimes hidden behind a “storage” sub-item).

Non-root apps cannot clean cache from other apps since around Android 6, which LTE cleaner also states – so that app won’t help with this case either. Without root, the way via Settings seems to be the only one available. Except you use a trick: Android Cache Cleaner (available in my repo) utilizes accessibility features to automate cache cleaning, should you want to do that for all apps. Reasons to need this are rather rare, though.

As for the other “things”: if you think you need that, you can find some candidates in my app list for System Cleanup.

2 Likes

I’ve tried the cache cleaner and it basically runs like SuperFreezZ, opening the different apps cache pages. But it’s not clicking and not cleaning anything. :thinking:

1 Like

Hm, going by the app description I had expected differently – but well, can’t be helped.

Hi @marcoXbresciani,

I’ve installed it and ran it once so far. Did work fine for me, it opened every App and cleaned its cache.

OK, the process was rather fast, but when you look at kb/mb digits it always goes down to zero…

Hello @michael_s. Yes, the process is very fast but still, at the end it sayd it has cleaned zero bytes and if I go to the cache through the system settings, the caches are still there.
Wondering if there’s something wrong with my configuration: I gave the accessibility permissions to the app, just like SuperFreezZ (that works), but it seems there’s something different.
Even Accessibility screens are different with respect to SuperFreezZ: there’s only the option for the accessible way of running the application, even if permissions have been granted.

And every time I re-open it, is asking again for Accessibility.
App installed from IzzyOnDroid, itself installed from F-Droid.
Granted “Usage Stats” permission and “Accessibility” as well.

Hi @marcoXbresciani ,
you’re right, I started the App again and didn’t get any information about the cleaned number of kb/mb at the end, too. :woozy_face:

So, I guess we have to trust the App, that it works the way it promises to do…

Good afternoon @Izzy

Thank you very much for your help and your time.

I was trying Android Cache Cleaner but it doesn’t clean any cache. I tried on my lineageos, on a friend’s pure Android. Who has one phone running Android 11 and another running Android 12.

The problem with giving it accessibility permissions. Is that it puts you a doll of a person in the part of the Android buttons.

I upload an image for you to see it: Screenshot-20221105-211514-Accessibility — ImgBB

I do not know if you could do that you do not ask for this permission. Or when the warning comes out that you can skip.

What I did not notice is what they say that always comes out that you give those permissions every time you open the application. The times I tried it only asks for it the first time it starts.

There is one thing that makes me strange. Since I tried the application that I commented @Morgoth . I mean LTE Cleaner . And note that this asks for access to storage and yours does not.

Screenshot of LTE Cleaner Screenshot-20221105-212044-Permission-controller — ImgBB

And Android Cache Cleaner Screenshot-20221105-212143-Permission-controller — ImgBB

The only thing when comparing it, without much programming knowledge. It occurs to me that maybe it lacks the permission to access the storage to do its function.

For example look at my brother in law’s phone, which uses sd maid (not open source as I did not see anywhere the same). But it also has the storage access permissions. I attach screenshot Screenshot-20221105-212441-Permission-controller — ImgBB

I apologize if I’m wrong. Or I screw up. It was not my intention. It’s just that I find it strange those changes in the permissions.

Best regards

If you’re comfy with adb, see this libreddit link

basically,
adb shell pm trim-caches 128G

I haven’t tried this myself, hope it works…

1 Like

@gallegonovato as I wrote, I never felt the need to purge all app caches at once – and I see no good reason doing so. Cache might need to be cleaned for a misbehaving app – but it’s never that all apps on your device are misbehaving, is it? So I go straight to Settings › Apps, scroll to the app concerned, and go to delete its cache. No need for an extra app to do that.

SDMaid is a great tool (which it were FOSS as many off the author’s other apps, and thus eligible for an F-Droid listing). It does not only take care for caches, but also for a lot of other things – and is very useful. Though not FOSS and not available at F-Droid, which is one of the reasons I no longer have it on any device here.

Oh, and I wish you wouldn’t all use such link shorteners. If you’d post the real ones, one could have a look – but this way I don’t know where I get into and thus don’t click them. or example, your Reddit link @Damjan would be nicely rewritten to Teddit if it were a Reddit link (Edit: Just fixed my rewriter to also consider r.nf as the rest of the URL matches). And your screenshots @gallegonovato might even show up right here :wink:

1 Like

Thanks for the link markup tip. I always confuse which brackets go where :rofl:

What is a “rewriter”?

A tool that rewrites. In this case: links in the browser. There are several Firefox-addons capable of such things, I use a GreaseMonkey script for that (this one from my collection here).

1 Like

Good afternoon @izzy

About clearing the cache massively, that’s not the problem. Since although it goes old my nexus 6p, it goes great. I use it with lineageos without gaps and without anything from google.

What if you upload the cache, is Adaway and Fdroid. And sometimes the browser. For example Adaway happens to me after updating the host lists. And fdroid when updating its repositories or if I have updates.

And for example Adaway sometimes I forget to clear the cache. And of course it closes in the middle of the process. It is that my mobile compared to some tremendous bugs that exist today because …

But if I clear the cache of Adaway, Fdroid everything goes great.

The browser then to visit web, and then when you update the lists ublock origin. It also uploads the cache.

But I commented it for those times that I forget to clean them :wink:

I also have it very controlled and trackers blocked with app manager (including permissions and so on). And then Autostarts from fdroid. And sometimes I run Hypatia from fdroid.

About the images because I do not understand why they do not come out. Since other times I uploaded screenshots or things. If they came out, and I did not do anything different. Well other times I also used the upload button that appears in the answers.

Best regards

Pd: I was missing comment that of the applications that I saw that people use to remove or free space and cache. All ask permission to storage and Android Cache Cleaner does not. That’s why maybe it does not work.

I never had such issues with Adaway, and neither with F-Droid (or I simply didn’t notice). But yes, as I wrote: single apps. No need to call on Chuck Norris for a roundhouse kick :see_no_evil:

Did you upload them here? Using the arrow-up button in the editor?

Good afternoon @Izzy

With Adaway maybe it happens to me as I have some very large lists. And after updating them, have adaway create and copy the new host. Then the cache goes up.

And my poor Nexus 6p as compared to other mobile as it will cost more. Since everything in technology does not stop growing. And now there are tremendous nuggets, which I doubt that you get their full potential.

About the images, in this topic I think I put the link. But other times I have done the same thing and I have posted the screenshots in the forum. But for next time I will try to upload pictures from the forum, to avoid these mishaps.

Thanks for your time and help.