AntennaPod: Outdated description

Hi,

AntennaPod’s description on F-Droid is outdated. The text might even be misleading (mentions unmaintained wiki, does not mention forum, mentions Flattr). The metadata yaml file does not specify a description and we specify the current one in our source repo using the TripleT gradle play publisher directory structure. The text in the source repo was updated a pretty long time ago (at least 2 releases) and is translated to various languages.

Why is the description not updated from the source repo? We put time into translating the description in the best way possible and F-Droid throws the translations away and does everything again (sometimes with lower quality). This is not a good use of people’s time. Can I somehow opt out of this and make F-Droid use the upstream description from the source repo instead?

3 Likes

That’s TripleT? Great… but the .YML Description/Summary fields override that, so… remove them from .YML, simples :wink:

In the case of AntennaPod, the yml file does not specify those fields and F-Droid still does not use the description from the source repo.

Ok, so maybe we have metadata in the tree…look: https://gitlab.com/fdroid/fdroiddata/-/blob/master/metadata/de.danoeh.antennapod/es/description.txt

so all these files in metadata/de.danoeh.antennapod/ need to be deleted too, open a MR :wink:

1 Like

The first commit that added these files says:

AntennaPod: use localizable texts to allow upstream’s translations

Are you sure that the upstream translations are used when deleting the files again?

Yes.
(type some stuff because discourse doesn’t allow me to just answer ‘Yes’ :D)

1 Like

Thanks to both of you (and for merging so quickly).

Off-Topic: I just wanted to mark the thread as solved but the button is not displayed. I think it would be nice if you could check this box in the discourse settings :slight_smile:

We have that already.

Maybe it depends on how you start the thread?

I started it using the “New Topic” button. My guess is that marking as solved is not enabled for all posts (using the system setting) but on a per-category basis (default discourse behavior). Looks like the #translation category does not have it enabled.

Done! :slight_smile:

1 Like