Activate new repo?


I am using F-Droid 1.17.0 on a FP3+ with /e/OS 1.13-s.

Now, I want to install Umbrella (Security First - Umbrella) and added the repository via QR-code.
Only the repository does not become activated since last Tuesday though I have checked daily updates to no avail.

What am I to do?

Do you have more info on what you did step-by-step and what error message you get, if any (preferably with a screenshot)? The following worked for me:

  1. Scan QR code on Umbrella in a QR scanner app (like Binary Eye)
  2. Copy the full URL that comes out of it to your clipboard (
  3. Go to F-Droid → Settings → Repositories → Add and see F-Droid automatically read the address and fingerprint from your clipboard
  4. Press Add

For me, this instantly worked on F-Droid 1.17.0. However, I couldn’t see the new app until I explicitly searched for Umbrella as it hasn’t been updated in 3 years and is therefore very far down the list.

That is, what I did.
I have in there, but it is “ungeprüft” (unchecked) so far as you can see:

It is told to look for updates every hour but doesn’t seem to.
A search for “umbrella” in F-Droid gives no result.

Try to toggle it off then on again

Allright, I’ll do it, though that’s a little odd.
I remember “Rebooting is not a repair technique.”

Isn’t there a way to tell the app to refresh or activate a repo?

So, meanwhile it is up again (shut off, no reboot) and a look into F-Droid is in vain: Nothing changed.

Any other hints?

Wait, what?

Try to toggle it THE REPO off then on again

Isn’t there a way to tell the app to refresh or activate a repo?

Yes, see above ^^^

Are you using Orbot? Did you toggle Tor usage in F-Droid? Or use Orbot in VPN mode? Can you try without Tor?

1 Like

Aaah, sorry.
Yes, that did the trick.
It started downloading at once, when I toggled it on again.
Even through Orbot.

I could download Umbrella now, though… their server seems to be down.
Call it a day and check tomorrow.

Thanks anyway.
Toggle the repo off and on…, yes, makes sense to me now.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.