Usability review of the privileged extension

I have tested the privileged extension recently and figured it may be useful to share my experience here. I first tried version “200”, but that failed for some reason - I don’t exactly remember why, but I ended up just removing it.

Now I have been able to install the “203” version along with the stable 0.102 client package. I sideloaded the .zip file I found on the website, after checking the GPG signature. (Note: I couldn’t find a trust path between my key and the signing key, or the keys signing the signing key, even though my key is in the strong set, so that’s something that may be improved…)

I did the sideload in TWRP, which worked fine, and restarted after flushing the Dalvik cache (although I’m not sure that’s absolutely required. (It would be nice to have step-by-step instructions on how to do that flashing for regular users, but I guess this is stuff people like me can do. :slight_smile: )

After the reboot, I decided to test upgrades and install. I had a rather confusing experience. I tapped the “refresh” button to fetch new sources, and F-Droid found some updates, which it promptly started downloading. After the download was completed, the progress bar was just full and nothing seemed to be happening. Until the download progress just disappeared without any further information.

Some packages disappeared from the list of updates - I guess they were uploaded?

I think it would be very useful if there would be a notification, when a package is installed in the background, that the install was completed. Something like “Package foo upgraded from 1.0 to 1.1 sucessfully” or something would go a long way in getting feedback… In particular, one of the apps that was being upgraded was f-droid itself, and that was even more confusing, because at some point f-droid shutdown and I ended up in the home screen. Tapping the f-droid app gave me an error like “No such app found”. The only way to return to F-Droid was to go back in the task list and tap the F-Droid window, which then resumed with the new version (presumably). (This is not a new problem with the privileged extension, mind you - i was having this all the time when f-droid would update itself.)

I haven’t tested the new alpha version - I will do so soon - but considering that last usability issue, I’m always scared that f-droid upgrading itself will break, even though it always manages to recover somehow…

Thanks for that extension, it’s a great improvement that makes F-Droid a real rival to the proprietary app managers. keep up the good work!

I have just tested the alpha release and it seems to fix the “notification” issue: when updates happen, i get notified. I am not sure however that automated updates still work - i had to tap around to make sure that the “Riot” app would actually install after the download…

Thanks for the writeup. 0.102.3 should also fix the notification issue. How would you make the updates more visible? We want to have a useful amount of info without getting in the way.

i guess updates are visible enough in the alpha release… or do you mean when new packages are available?

Yup, there is indeed a notification in the 0.103 alpha releases along the lines of “Installation completed”. This will show not just in the notification manager, but also in the “Updates” tab within F-Droid.

Actually, the alpha is great but one thing that is missing is some information about the version changes. Did I just upgrade package foo from 1.0 to 2.0 or from 1.0 to 1.1? are there any release notes? It would be great if the notification would include version numbers and, if possible, a link to the changelog…

Otherwise I can confirm the alpha automatically updates f-droid packages quite neatly. It’s pretty awesome - so much tappy-tapping time saved! :wink: Thanks!

A text for “What’s New” or “Recent Changes” is now supported. If an app includes that, it’ll be shown on the App Details screen for any app that you have installed. That’s not common yet. What is more common is a link to the ChangeLog in the links section of App Details.

That’s something that needs to be added for every release? It seems unlikely people will do this… I would rather have a link to something that works now. :wink:

How about adding version details in the notification? Is that planned?

Writing a entry in the same ChangeLog file is the really the same amount
of work as writing that same text in a new file for each release. Its
optionaly, but someone has to write it if they want that info to be
available to users, there is no way around that.

About putting more stuff in the notification, that’ll rapidly make it
confusing. The notifications take you quickly to the most common
actions, and for the overview of everything, there is the App Details

No it’s not: it’s twice the work. :slight_smile:

I disagree - it’s just one string… Right now I have very little visibility on what happened. e.g. I know that Conversations was updated, but from where to where? No idea. Before, when I was explicitly choosing updates to apply, I had that level of control, which is lost. I don’t mean for the notification to take me to a separate screen: just say “Conversations upgraded from 1.16.0 to 1.16.2” instead of “Conversations installed”…

Another issue that came up here is the update of the privileged extension itself. Here, there’s a pending update of that extension, which F-Droid can’t seem to apply, probably because it was installed with a OTA update. I tried dismissing the dialog a few times but it kept coming back… Now it’s gone, but I bet it will be back in a week when F-Droid checks for updates again… :wink:

There was a usability bug in the process that makes the OTA ZIP. That’s
fixed in 0.2.4, so if you flash 0.2.4, then F-Droid will be able to
directly update Privileged Extension after that.

Thanks, it looks better now!