Is the F-Droid build process currently broken?

#48

Hi @relan, how can I check the auto-build of my app (above)?
I don’t have info.

Rem: +1 to stop some app building that will slow the whole build process.
I also see an app in Fdroid with maybe10 separated apps, maybe they need a dedicated server lol :smiley:
(or special conditions to build them as last)

Edit: ticket solved about Gitlab shared runners

#49

@hotlittlewhitedog, there is a wiki that is auto-updated by the build process, although sometimes it is a trailing indicator (it can take a few days to get updated after the actual build has processed).

https://f-droid.org/wiki/page/org.hlwd.bible

There is also build log (also a trailing indicator. but usually updated more quickly than the general wiki):

https://f-droid.org/wiki/index.php?title=org.hlwd.bible/lastbuild&redirect=no

This shows that there hasn’t been an attempt to build your APK since October 10.

Other apps are building fine:

https://f-droid.org/wiki/index.php?title=Special:RecentChanges&hidebots=0

The metadata for you app shows that it isn’t trying to build any newer version. Because Auto Update Mode is set to none, you or someone else will need to manually edit the metadata file to initialize the build process.

I would recommend changing the metadata file to use some form of auto updating:

https://f-droid.org/docs/Build_Metadata_Reference/#Update-Check-Mode

For my app, I use Tags, which automatically adds a new build section based on release tags in my repo.

1 Like
#50

ok thanks a lot @sorenstoutner, I will check this :blush:

1 Like
#51

I was checking the build status just now, and find many apps are failed with this error:

INFO: Cleaning Gradle project...
ERROR: Could not build app APP_ID: OSError while trying to execute gradle clean: [Errno 8] Exec format error

This seems to indicate some (or one) gradle-related files lack their shebang?

1 Like
#52

Hmm, buildserver/gradle does have #!/bin/bash at the top…

1 Like
#53

Hi all,
Will be the FAILED applications rebuilt?
Or do we have to make an update to force the auto-update?

1 Like
#54

Yes, that is always the case.

1 Like
#55

ok, do you have an estimate for fixing this issue? (blocking a lot of apps)

1 Like
#56

We have the whole build process running smoothly now on our testbed on jenkins.debian.net. Now we have to get that all deployed on the production servers, which takes time.

3 Likes
#57

Is there an estimate on when app updates currently held back will be published, that I could communicate to users of my app waiting for the last version?

2 Likes
#58

We have just merged a fix that hopefully will work around the most major problem right now: https://gitlab.com/fdroid/fdroidserver/merge_requests/437

That will need a few more days of testing before it’ll get deployed. After that the buildserver can hopefully start working through that backlog here: https://f-droid.org/wiki/page/Category:Apps_with_failing_builds

(It’s called failing builds, but most of these are just unbuilt-apps)

It’'ll still take a week or so to built ~150 apps probably.

4 Likes
#59

I don’t see my app in the failing builds however no recent update was done. The latest checkpatch https://f-droid.org/wiki/page/checkupdates_1517395564
was processing my app “Processing com.gacode.relaunchx”.

#60

Same for https://f-droid.org/wiki/page/org.hlwd.bible
No build logs, please check.
Could be the screenshots with fastlane.

#61

Edit: could have screenshots ref incorrect, not shown in the tag version.

Seems Ok now, I recreated the tag, ref OK.
Could you relaunch the build?

#62

The wiki indicates that the build for version 2.8 of Privacy Browser has failed:

https://f-droid.org/wiki/index.php?title=com.stoutner.privacybrowser.standard&curid=27229&diff=212808&oldid=210754

But the link to the build log is broken:

https://f-droid.org/wiki/page/com.stoutner.privacybrowser.standard/lastbuild_30

Is there any way to find out what went wrong?

#63

@sorenstoutner, this means buildserver haven’t even tried to build Privacy Browser yet, only updated metadata and wiki (same story with other apps). Should be built in today’s batch.

2 Likes
#64

Yes, it finally did build (and without issue).

Would it be possible to update the wiki bot so it could differentiate between a build that is failing and a build that hasn’t yet been attempted?

1 Like
#65

a build count (restarting at 1 for a new update) could be even better ^^

#66

I’ve been getting issues with fdroidserver as well. Installing it through pyvenv fdroidserver-env works somewhat, but fdroid update fails with an ascii parsing error, and if I try fdroid build -v -l org.strawberryforum.pollywog, the build fails due to a 404 error as it couldn’t retrieve the relevant libraries or something. Pulled my hair out for hours on this due to how convoluted it is! And what bugs me is that I am able to build it through Android Studio.

closed #67

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Mastodon