I cannot update Tor Browser

Indeed. As they say, pull requests are welcomed.

1 Like

Depends on the audience you have in mind. For Tor Browser I was able to get an update by using Google Play instead. Nerds may have a different solution, but honestly:
What is it worth to see an update being announced as being available when you cannot get it through the same program?

2 Likes

The About is clear. https://f-droid.org/en/about/ It is for passionate FOSS supporters. Things get fixed when someone gives enough of their time or money to get it done. It is on the todo list: https://gitlab.com/groups/fdroid/-/issues?scope=all&state=all&search=mirror
Thanks @hans !

1 Like

Good afternoon:

First of all thank you all for your answers and help.

I was finally able to update Tor from the fdroid application.

Today I gave to update to fdroid. It told me that I had several updates. Among them, another new Tor update. I was able to download all of them, except the Tor one. I got the error again.

What I did, is to go to fdroid application settings, then repositories. There I looked at the one that says Guardian Project Official Release:

Click on the name and I got three mirrors or addresses:

Uncheck the last two. Close Fdroid. Clear the Fdroid cache. Then just in case, I ran Lte Cleaner from fdroid.

I went back into the fdroid app. I sent it to update. It did what it was supposed to do. And then I went to settings, installed applications. There I searched for Tor. I hit update, it took a little while but it started downloading the update. And then it told me to install.

I installed it and Tor is up to date.

I tried on another phone and with the two checked that I put in the screenshot also goes.

I hope it can be of help to you too.

The bad thing is that Tor has Trackers and Loggers. Checked with fdroid app manager and gitlab warden (also this in xda)

I do not know if you can remove those trackers and loggers?

A hug and thanks to all.

this should be fixed now. For the backstory, see

1 Like

So basically the issue was that the URL being used did not provide the object; maybe for a “404” the recovery would be to try another URL if present.
For the gitlab thing: Wouldn’t a “git status” tell you that your local workspace is ahead of the (remote) repository if “the push” had failed?

The related problems are well mapped out, they just need people to work on them.
I’ll be working on this in Sept:

And other issues which are waiting for contributors:

There are only three options for me, but none of them work.
Do I need to install Tor from the Google Play Store?

There are only three options for me, but none of them work.

You’ve “touch and scrolled down” to see them all? Do you see guardianproject dot info ?

Do I need to install Tor from the Google Play Store?

I cannot tell you what you need, without you telling me what you really seek. LOL

torproject dot org and its download links, from homepage and blog, may show you the light. :laughing:

Thank you for your help!! Great!!
Now it works fine. :slightly_smiling_face: